2

Preface #1 : I'm not using a Virtual Machine

Preface #2 : during the installazion I skipped the Network Mirror step

Preface #3 : I never used Linux before

I have a laptop and I can connect to my WiFi network.

The problem is that I can't connect to the outside world!

ping www.google.com
ping: unknown host www.google.com

Iceweasel won't work either.

This is my ifconfig enter image description here

The Proxy is set to None

enter image description here

This is my Access Point configuration (IPv4)

enter image description here

And, since I skipped the Network Mirror configuration at installation time, I read on some forums I needed to add two lines in the sources.list

enter image description here

Please, I've been struggling for hours by now.

Does anyone of you know the reason of this issue?

P.S: Sometimes, I could load the Google page and I could make the ping work... umh, maybe my laptop network driver is just too weak? I'm far 3 meters from the router...

P.S2: I tried to connect my laptop to my router via Ethernet cable. It works! But why can't I connect via WiFi?

  • First of all get an IP address. As far as I see you don't have an IP address assigned in the wlan0 interface (ifconfig wlan0)...Your router should assign you one if it works as DHCP server, which most of them do... After that check that /etc/resolv.conf contains a DNS address (e.g. 8.8.8.8 or 8.8.4.4) => nameserver 8.8.8.8 – marc Jul 28 '16 at 13:41
  • Thanks for the answer. How do I assign an IP address to my wlan0? – gedamial Jul 28 '16 at 13:44
  • sudo dhclient -r wlan0 – marc Jul 28 '16 at 13:47
  • ifdown wlan0 && ifup wlan0 – marc Jul 28 '16 at 13:48
  • Thanks for the availability First of all I tried assigning my wlan0 an IP address, but it didn't seem to work. Screenshot > prntscr.com/bymr39 Then I checked the resolv.conf file and it turned out it's empty. Screenshot > prntscr.com/bymrpx What's happening? – gedamial Jul 28 '16 at 13:55
4

On Kali Linux you have just needed to run this first

airmon-ng check kill

This command stops network managers then kill interfering processes left

Source and other useful information: https://www.aircrack-ng.org/doku.php?id=airmon-ng

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.