4

I have my 1TB hard drive split even between ubuntu 14.04 and windows 10.

wifi and ethernet work great in windows, and wifi works great in ubuntu--for about five minutes. ethernet doesn't really work at all anymore, but it used to. the icon stays as though i'm connected, but i can't access perform any functions that would require an internet connection.

here's the result from ifconfig:

eth0      Link encap:Ethernet  HWaddr 1c:39:47:21:2a:d9  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:165 errors:0 dropped:0 overruns:0 frame:0
      TX packets:165 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:11993 (11.9 KB)  TX bytes:11993 (11.9 KB)

wlan0     Link encap:Ethernet  HWaddr 30:52:cb:74:e0:53  
      inet addr:192.168.0.13  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::3252:cbff:fe74:e053/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:183 errors:0 dropped:0 overruns:0 frame:0
      TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:17470 (17.4 KB)  TX bytes:26540 (26.5 KB)

for my network adapters:

ETHERNET: Realtek PCIe GBE Family Controller WIRELESS: Qualcomm Atheros QCA61x4 Wireless Network Adapter

4
  • Can you ping your router? Can you ping e.g. stackexchange.com?
    – FelixJN
    Commented Jul 28, 2016 at 13:28
  • Edit to include results for iwconfig
    – Jeremy31
    Commented Jul 29, 2016 at 10:24
  • @Jeremy31 iwconfig results eth0 no wireless extensions. wlan0 IEEE 802.11abgn ESSID:"BHNTC8715D64AD" Mode:Managed Frequency:2.437 GHz Access Point: 08:95:2A:61:64:B3 Bit Rate=1 Mb/s Tx-Power=20 dBm Retry short limit:7 RTS thr:off Fragment thr:off Power Management:on Link Quality=70/70 Signal level=-27 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:197 Missed beacon:0 lo no wireless extensions. Commented Jul 31, 2016 at 9:34
  • @Fiximan ping 192.168.0.1 PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data. From 192.168.0.12 icmp_seq=1 Destination Host Unreachable From 192.168.0.12 icmp_seq=2 Destination Host Unreachable 64 bytes from 192.168.0.12: icmp_seq=18997 ttl=64 time=7.56 ms 64 bytes from 192.168.0.12: icmp_seq=18998 ttl=64 time=43.0 ms ping: sendmsg: No buffer space available ping: sendmsg: No buffer space available 19021 packets transmitted, 18588 received, +369 errors, 2% packet loss, time 19856151ms ping: sendmsg: No buffer space available ping: sendmsg: No buffer space available Commented Jul 31, 2016 at 9:40

5 Answers 5

4

Disable wifi power management with

sudo iwconfig wlan0 power off
Then test the connection to see if it improves

1
  • Wow. Thank you so much. This fixed the issue for me.
    – bluelurker
    Commented May 13, 2021 at 14:52
1

According to wireless.wiki.kernel , there are two way to get the wifi working:

1) Compile a new kernel version at least the 4.0

or

2) Using backport

It is possible to use newer ath10k driver on an older kernel with backports project.

Download latest backports release from here and unpack it.

Run defconfig for ath10k:

make defconfig-ath10k

Compile backports:

make

Install backports:

sudo make install

Reboot system and ath10k should load automatically.

0

Open /etc/resolv.conf and check that it contains a valid DNS server (e.g. google):

nameserver 8.8.8.8

Normally when modified you won't need to restart the network manager, as it will detect and apply the changes.

1
  • i believe it has a valid dns server but just in case CONTENTS OF RESOLV.CONF # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN nameserver 127.0.1.1 Commented Jul 31, 2016 at 9:43
0

I faced a similar problem after changing the wifi router.

The solution that worked for me, was to set the router wifi mode to b/g only.

0

For me was a combination of turning off the Power Management for the wlan and removing unused Docker networks:

Get the wlan name with "ifconfig" and:

sudo iwconfig <wlan_name> power off
docker network prune

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .