2

Wicd suddenly started to ask for password at startup,

"Wicd needs to access your computer's network cards"

sometimes followed by this error messages:

"Could not connect to wicd's D-Bus interface. Check the wicd log for error messages"

Never did it before, what I did is:

  • Installed xampp
  • Installed chkconfig
  • Disabled Apache2 at startup with # chkconfig apache2 off
  • Enabled xampp at startup using this guide: start xampp at startup

Any hints? My distro is Debian 8.

EDIT

Even If I check options to remember password when prompted, password is asked each boot.

Log content /var/log/wicd/wicd.log:

2016/07/28 09:23:21 :: ---------------------------
2016/07/28 09:23:21 :: wicd initializing...
2016/07/28 09:23:21 :: --------------------------- 
2016/07/28 09:23:21 :: wicd is version 1.7.2.4 768
2016/07/28 09:23:21 :: setting backend to external
2016/07/28 09:23:21 :: trying to load backend external
2016/07/28 09:23:21 :: successfully loaded backend external
2016/07/28 09:23:21 :: trying to load backend external
2016/07/28 09:23:21 :: successfully loaded backend external
2016/07/28 09:23:21 :: Automatically detected wireless interface wlan0
2016/07/28 09:23:21 :: setting wireless interface wlan0
2016/07/28 09:23:21 :: automatically detected wired interface eth0
2016/07/28 09:23:21 :: setting wired interface eth0
2016/07/28 09:23:21 :: setting wpa driver wext
2016/07/28 09:23:21 :: setting use global dns to False
2016/07/28 09:23:21 :: setting global dns
2016/07/28 09:23:21 :: global dns servers are None None None
2016/07/28 09:23:21 :: domain is None
2016/07/28 09:23:21 :: search domain is None
2016/07/28 09:23:21 :: setting automatically reconnect when connection drops     True
2016/07/28 09:23:21 :: Setting dhcp client to 0
2016/07/28 09:23:21 :: Wireless configuration file found...
2016/07/28 09:23:21 :: Wired configuration file found...
2016/07/28 09:23:21 :: chmoding configuration files 0600...
2016/07/28 09:23:21 :: chowning configuration files root:root...
2016/07/28 09:23:21 :: Using wireless interface...wlan0
2016/07/28 09:23:21 :: Using wired interface...eth0
2016/07/28 09:23:26 :: Autoconnecting...
2016/07/28 09:23:26 :: No wired connection present, attempting to autoconnect to wireless network
2016/07/28 09:23:27 :: trying to automatically connect to...glab
2016/07/28 09:23:27 :: Connecting to wireless network glab
2016/07/28 09:23:27 :: attempting to set hostname with dhclient
2016/07/28 09:23:27 :: using dhcpcd or another supported client may work better
2016/07/28 09:23:28 :: attempting to set hostname with dhclient
2016/07/28 09:23:28 :: using dhcpcd or another supported client may work better
2016/07/28 09:23:28 :: Putting interface down
2016/07/28 09:23:28 :: Releasing DHCP leases...
2016/07/28 09:23:28 :: attempting to set hostname with dhclient
2016/07/28 09:23:28 :: using dhcpcd or another supported client may work better
2016/07/28 09:23:28 :: Setting false IP...
2016/07/28 09:23:28 :: Stopping wpa_supplicant
2016/07/28 09:23:28 :: Flushing the routing table...
2016/07/28 09:23:28 :: Putting interface up...
2016/07/28 09:23:30 :: Generating psk...
2016/07/28 09:23:30 :: Attempting to authenticate...
2016/07/28 09:23:32 :: Running DHCP with hostname camera50
2016/07/28 09:23:32 :: attempting to set hostname with dhclient
2016/07/28 09:23:32 :: using dhcpcd or another supported client may work better
2016/07/28 09:23:32 :: Internet Systems Consortium DHCP Client 4.3.1
2016/07/28 09:23:32 :: Copyright 2004-2014 Internet Systems Consortium.
2016/07/28 09:23:32 :: All rights reserved.
2016/07/28 09:23:32 :: For info, please visit https://www.isc.org/software/dhcp/
2016/07/28 09:23:32 :: 
2016/07/28 09:23:32 :: Listening on LPF/wlan0/b8:86:87:ad:78:41
2016/07/28 09:23:32 :: Sending on   LPF/wlan0/b8:86:87:ad:78:41
2016/07/28 09:23:32 :: Sending on   Socket/fallback
2016/07/28 09:23:32 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
2016/07/28 09:23:32 :: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
2016/07/28 09:23:32 :: DHCPOFFER from 192.168.0.1
2016/07/28 09:23:32 :: DHCPACK from 192.168.0.1
2016/07/28 09:23:32 :: bound to 192.168.0.114 -- renewal in 35290 seconds.
2016/07/28 09:23:32 :: DHCP connection successful
2016/07/28 09:23:32 :: not verifying
2016/07/28 09:23:33 :: Connecting thread exiting.
2016/07/28 09:23:34 :: Sending connection attempt result success

EDIT 2

Seems to me that the above log doesn't show any relevant information, probably because it log information after the daemon starts, but my issue occurs before it! I think it's something related to timing issue, as when I'm prompted for the password it doesn't matter what I choose, even I click "cancel" I receive the second error but tray icon works and wi-fi connection works. I already checked configuration files in /etc/wicd but there is nothing strange, no empty brackets as someone suggest to fix this problem. Already tried to edit manager-settings.conf in sudo_app=1 without any success. Just to recap the problem started disabling Apache2 and installing Xampp, enabling it at startup. My idea is that wicd-client doesn't wait for wicd daemon and that's why I'm prompted for the password, to start the daemon! But the daemon starts anyway as expected (even choosing cancel! ). Any help will be appreciated.

  • I don't have /run/resolvconf/resolv.conf in my system .. – rok Jul 28 '16 at 7:37
  • What does the log say? – Fiximan Jul 28 '16 at 7:40
  • edited with more details – rok Jul 28 '16 at 8:15
-1

I found a similar problem in ubuntuforums.org.

There, the solution apparently is:

sudo apt-get install sysv-rc-conf
sudo sysv-rc-conf

A window will show. Arrow down near the end to "wicd". Use the spacebar to put an X in 2, 3, 4, & 5. Enter q to quit. Reboot.

Edit:

Try this:

edit config file from terminal console:

gedit /etc/wicd/manager-settings.conf

search for:

sudo_app = 0

change to:

sudo_app = 1

Source: Link

  • 1
    tried with no luck – rok Oct 18 '16 at 10:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.