0

I'm running RHEL version 6.7 on a server, and am having trouble installing EPEL.

Since I'm running RHEL version 6.7 I was told I needed a 6.x version of EPEL. So I installed:

epel-release-6-8.noarch

However, after installing, every time I would run a 'yum' command, it would return the error

xz compression not available

So I had to uninstall.

Am I doing something wrong?

  • What is your tar version? – FarazX Jul 27 '16 at 14:48
  • Be aware that xz works only from tar 1.22 (march 2009). – FarazX Jul 27 '16 at 14:52
  • @FarazX , I have version 1.23 , do I need to downgrade? Thanks – Edon Jul 27 '16 at 17:47
  • no not at all! I'm going to write you an answer with all steps needed. – FarazX Jul 27 '16 at 17:57
1

I recommend you read this article since it can help you much.

All you need, is to do steps below:

  • First of all, remove epel-release: yum remove epel-release

  • Then, delete it from rm -rf /var/cache/yum/x86_64/6/epel or the 32 bit version if your system is 32 bit, and then you need to install the correct epel-release package. So download the correct epel-release RPM - the one which suits your system architecture - and then install it.

  • Finally, you should install pyliblzma since that will allow the RHEL6 yum to handle the xz repodata specially those used in epel.

    yum install pyliblzma

And then it will work.

0

First you need to remove the epel-release:

yum remove epel-release

Remove the cached files for epel under /var/cache/yum/...

Then enable EPEL Repository:

RHEL 6 32-Bit

wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm

RHEL 6 64-Bit

wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm
  • Thanks! I will try this after making sure I have the right version of tar installed (currently: 1.23) – Edon Jul 27 '16 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.