1

I'm using Arch and last night I was going through the Beginner's Guide and set up all the partitions, downloaded the required base and base-devel files and I thought everything was okay.

However, I realised that since I have Windows already installed, I already have an EFI system partition on /dev/sdc1 so I didn't need to create a new one at /dev/sdb1. I have already generated my fstab file so I'm assuming I need to change the boot from /dev/sdb1 to /dev/sdc1 - However I'm unsure if this is as simple as editing /mnt/etc/fstab or I need to do something a little more complicated.

My second smaller problem is that to get the USB installer to boot, I needed to use the nomodeset option, however, I forgot to make it permanent so I need to do it again - but with Arch booting straight into the boot device I can't press e on the options menu to add nomodeset. How can I do this?

0

You can try copying the contents of /dev/sdb1 to /dev/sdc1 (while preserving the structure of the data) and then change the mount options in /etc/fstab to point at /dev/sdc1 for the boot partition. If you are able to boot successfully, that's good but if you aren't, then you can always use a live USB to chroot into your Arch Linux installation and revert the changes. Note that you should use UUIDs instead of partition names in your /etc/fstab file.

If you're using systemd-boot, edit the /boot/loader/entries/*.conf file and add nomodeset to the options row in the file. Note that I wrote *.conf to indicate the file name of the configuration file which can be anything that you've set. If you're using GRUB, I think that you need to edit the /etc/default/grub file and add nomodeset to GRUB_CMDLINE_LINUX_DEFAULT and then run sudo update-grub afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.