0

I'm actually having error on this setup. I'm getting
500 Illegal PORT command.
425 Use PORT or PASV first
when go using command PUT.

I'm currently using CENTOS 7.2

Here's my vsftpd.conf:

anonymous_enable=NO
listen_port=58021
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
xferlog_std_format=YES
listen=NO
listen_ipv6=YES
pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
dirlist_enable=yes

pasv_enable=yes
pasv_min_port=58022
pasv_max_port=58026
write_enable=yes

local_root=/mnt/webcollab/super/

Already tried the fix on the internet and forums.

http://www.linuxquestions.org/questions/linux-networking-3/vsftpd-425-error-57491/

and same what I saw here in exchange and still having issue.

Thanks!

  • did you try pasv_promiscuous=YES as mentioned in the link? – meuh Jul 27 '16 at 9:03
  • @meuh Yes I already tried – Edmhar Jul 28 '16 at 0:22
1

I think there is a problem with your ftp client.

The PORT command is sent by the FTP client. If the supplier sends a PORT command with a 10.x.x.x address all the way to the server that will never work because the 10.x.x.x is a private range. There are only two ways that a client can send 10.x.x.x in a port command and expect it to work:

  1. The client is on the same private 10.x.x.x network as the server.
  2. The firewall on the client's network is protocol-aware of FTP and inspects the control channel in real time and actually replaces the 10.x.x.x internal address with an external IP address so that the server will actually see the external address rather than the client's internal 10.x.x.x address.

Read the complete thread here on this issue

For a quick check , disable the firewall and selinux on ftp server temporarily to see it is related to that or not.

  • so this causing from a NAT Network? – Edmhar Jul 28 '16 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.