4

I'm having a looping issue with Linux Mint 18 where it cannot get out of the same repeated cycle of "Failed to launch desktop manager" with that blue graphic screen asking me if I want to look at the logs.

This was a fresh new install of Mint 18 and I cannot for the life of me get Nvidia drivers installed without it screwing up Xorg where it complains it can't find a screen.

The usual way was to just install from Driver Manager and would work just like that, but its gone back to its old ways just like 4 versions ago where it will screw up no matter what you do.

I have repeatedly purged the system over and over of Nvidia drivers, old and stale Xorg config files, the shitty nouveau drivers which usually is the cause of it not working when you install Nvidia drivers. Ivebtried seeking help on some forums but have yet to have any feedback help on what to do and my patience is running thin because I need all of this to work as smoothly and as flawlessly as possible as its setting me behind on my work projects.

When I remove Nvidia drivers it decides it'll be normal and work OK off Intel graphics, but I cannot run any applications that requires OpenGL. This is the part that pisses me off the most, if it can run normal off Intel graphics chip, why not Nvidia too?!

(EE) Fatal Error:
(EE) no screens found (EE)

(==) Using config file "/etc/X11/Xorg.conf"
(==) Using system config directory "/use/share/X11/Xorg.come.d"
(==) ServerLayout "layout"
(**) |-->Screen "nvidia" (0)
(**) |   |-->Monitor "<default monitor >"
(**) |   |-->Device "nvidia"
(**) |   |-->GPUDevice "Device0"
(**) |   |-->GPUDevice "intel"
(**) |   |-->GPUDevice "nvidia"
(==) No monitor specified for "nvidia".
        Using a default monitor configuration.
(**) |   |-->Inactive Device "intel"

First of all, that from the Xorg.0.log doesn't make sense. Because A) Inter should not be inactive after install. And B) Monitor isn't suppose to attach to Nvidia, only Intel, because I was going to use Bumblebee and Optimus so that Intel runs the screen while Nvidia runs the rendering for programs that need it as its called. I don't care for the power saving feature that Primus offers.

So my setup should be as simple as this

[Intel] - - - - \
                 > - - - {Monitor}
                 >- - - {Rendering}
[NVIDIA] - - - /

EDIT:** here's a longer detailed Xorg log output.

[   162.343]  X.Org X Server 1.18.3 Release Date: 2016-04-04 [  
162.343] X Protocol Version 11, Revision 0 [   162.343] Build Operating System: Linux 3.13.0-86-generic x86_64 Ubuntu [   162.343] Current Operating System: Linux Roofox 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 [   162.343] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic root=UUID=87d32912-b8e0-4dda-8182-230938e4f8c5 ro quiet splash vt.handoff=7 [   162.343] Build Date: 18 May 2016  01:07:07AM [  
162.343] xorg-server 2:1.18.3-1ubuntu2.2 (For technical support please see http://www.ubuntu.com/support)  [   162.343] Current version of pixman: 0.33.6 [   162.343]  Before reporting problems, check http://wiki.x.org  to make sure that you have the latest version. [  
162.343] Markers: (--) probed, (**) from config file, (==) default setting,     (++) from command line, (!!) notice, (II) informational,    (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [  
162.343] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 27 17:47:11 2016 [   162.344] (==) Using system config directory "/usr/share/X11/xorg.conf.d" [   162.344] (==) No Layout section.  Using the first Screen section. [   162.344] (==) No screen section available. Using defaults. [   162.344] (**) |-->Screen "Default Screen Section" (0) [   162.344] (**) |   |-->Monitor "<default monitor>" [   162.344] (==) No device specified for screen "Default Screen Section".  Using the first device section listed. [   162.344] (**) |   |-->Device "Device1" [   162.344] (**) |   |-->GPUDevice "Device0" [   162.344] (==) No monitor specified for screen "Default Screen Section".     Using a default monitor configuration. [   162.344] (==) Automatically adding devices [   162.344] (==) Automatically enabling devices [   162.344] (==) Automatically adding GPU devices [ 
162.344] (==) Max clients allowed: 256, resource mask: 0x1fffff [   162.344] (==) FontPath set to:  /usr/share/fonts/X11/misc,  /usr/share/fonts/X11/cyrillic,  /usr/share/fonts/X11/100dpi/:unscaled,  /usr/share/fonts/X11/75dpi/:unscaled,   /usr/share/fonts/X11/Type1,     /usr/share/fonts/X11/100dpi,    /usr/share/fonts/X11/75dpi,     built-ins [   162.344] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules" [   162.344] (II) The server relies on udev to provide the list of input devices.    If no devices become available, reconfigure udev or disable AutoAddDevices. [   162.344] (II) Loader magic: 0x55a1bfc6dda0 [   162.344] (II) Module ABI versions: [   162.344]  X.Org ANSI C Emulation: 0.4 [   162.344]    X.Org Video Driver: 20.0 [   162.344]   X.Org XInput driver : 22.1 [   162.344]     X.Org Server Extension : 9.0 [   162.345] (++) using VT number 8

[   162.345] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration [  
162.345] (II) xfree86: Adding drm device (/dev/dri/card1) [   162.345] (II) xfree86: Adding drm device (/dev/dri/card0) [   162.347] (--) PCI:*(0:0:2:0) 8086:0166:1043:1477 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64 [   162.347] (--) PCI: (0:1:0:0) 10de:0de9:1043:1477 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288 [   162.347] (II) LoadModule: "glx" [   162.347] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so [   162.359] (II) Module glx: vendor="X.Org Foundation" [   162.359]    compiled for
1.18.3, module version = 1.0.0 [   162.359]     ABI class: X.Org Server Extension, version 9.0 [   162.359] (==) AIGLX enabled [   162.359] (II) LoadModule: "intel" [   162.359] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so [   162.360] (II) Module intel: vendor="X.Org Foundation" [   162.360]    compiled for 1.18.1, module version = 2.99.917 [   162.360]     Module class: X.Org Video Driver [   162.360]   ABI class: X.Org Video Driver, version 20.0 [  
162.360] (II) LoadModule: "nvidia-361" [   162.360] (WW) Warning, couldn't open module nvidia-361 [   162.360] (II) UnloadModule: "nvidia-361" [   162.360] (II) Unloading nvidia-361 [   162.360] (EE) Failed to load module "nvidia-361" (module does not exist, 0) [  
162.360] (==) Matched intel as autoconfigured driver 0 [   162.360] (==) Matched nvidia as autoconfigured driver 1 [   162.360] (==) Matched nouveau as autoconfigured driver 2 [   162.360] (==) Matched intel as autoconfigured driver 3 [   162.360] (==) Matched modesetting as autoconfigured driver 4 [   162.360] (==) Matched fbdev as autoconfigured driver 5 [   162.360] (==) Matched vesa as autoconfigured driver 6 [   162.360] (==) Assigned the driver to the xf86ConfigLayout [   162.360] (II) LoadModule: "intel" [   162.360] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so [   162.360] (II) Module intel: vendor="X.Org Foundation" [   162.360]    compiled for 1.18.1, module version = 2.99.917 [   162.360]     Module class: X.Org Video Driver [   162.360]   ABI class: X.Org Video Driver, version 20.0 [   162.360] (II) UnloadModule: "intel" [   162.360] (II) Unloading intel [   162.360] (II) Failed to load module "intel" (already loaded, 21921) [   162.360] (II) LoadModule: "nvidia-361" [  
162.360] (WW) Warning, couldn't open module nvidia-361 [   162.360] (II) UnloadModule: "nvidia-361" [   162.360] (II) Unloading nvidia-361 [   162.360] (EE) Failed to load module "nvidia-361" (module does not exist, 0) [   162.360] (II) LoadModule: "nvidia" [   162.360] (WW) Warning, couldn't open module nvidia [   162.360] (II) UnloadModule: "nvidia" [   162.360] (II) Unloading nvidia [   162.360] (EE) Failed to load module "nvidia" (module does not exist, 0) [   162.360] (II) LoadModule: "nouveau" [   162.361] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so [   162.361] (II) Module nouveau: vendor="X.Org Foundation" [   162.361]    compiled for 1.18.1, module version = 1.0.12 [   162.361]   Module class: X.Org Video Driver [   162.361]   ABI class: X.Org Video Driver, version 20.0 [   162.361] (II) LoadModule: "modesetting" [   162.361] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so [   162.361] (II) Module modesetting: vendor="X.Org Foundation" [   162.361]     compiled for 1.18.3, module version = 1.18.3 [   162.361]   Module class: X.Org Video Driver [   162.361]   ABI class: X.Org Video Driver, version 20.0 [   162.361] (II) LoadModule: "fbdev" [   162.361] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so [   162.361] (II) Module fbdev: vendor="X.Org Foundation" [   162.361]   compiled for 1.18.1, module version = 0.4.4 [   162.361]    Module class: X.Org Video Driver [   162.361]   ABI class: X.Org Video Driver, version 20.0 [   162.361] (II) LoadModule: "vesa" [   162.361] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so [   162.361] (II) Module vesa: vendor="X.Org Foundation" [   162.361]  compiled for 1.18.1, module version = 2.3.4 [   162.361]    Module class: X.Org Video Driver [   162.361]   ABI class: X.Org Video Driver, version 20.0 [   162.361] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:  i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,     915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43 [   162.362] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000 [   162.362] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100 [   162.362] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300 [   162.362] (II) NOUVEAU driver Date:   Tue Dec 8 15:52:25 2015 +1000 [   162.362] (II) NOUVEAU driver for NVIDIA chipset families : [   162.362]  RIVA TNT        (NV04) [   162.362]     RIVA TNT2       (NV05) [   162.362]     GeForce 256     (NV10) [   162.362]     GeForce 2       (NV11, NV15) [  
162.362]    GeForce 4MX     (NV17, NV18) [   162.362]   GeForce 3       (NV20) [   162.362]     GeForce 4Ti     (NV25, NV28) [   162.362]   GeForce FX      (NV3x) [   162.362]     GeForce 6       (NV4x) [  
162.362]    GeForce 7       (G7x) [   162.362]  GeForce 8       (G8x) [   162.362]  GeForce GTX 200 (NVA0) [   162.362]     GeForce GTX 400 (NVC0)

EDIT 2 **

4.4.0-21-generic

mint-meta-cinnamon:
  Installed: 2016.07.23
  Candidate: 2016.07.23
  Version table:
 *** 2016.07.23 500
        500 http://packages.linuxmint.com sarah/main amd64 Packages
        500 http://packages.linuxmint.com sarah/main i386 Packages
        100 /var/lib/dpkg/status

-

Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF108M [GeForce GT 630M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 drivers: nouveau,intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.03hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes

EDIT 3 **

/etc/X11/xorg.conf.new file

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
  • Yes, X -configure created xorg.conf.new but then follows up to tell me to test it with X -config /root/Xorg.conf.new to see if it works. But still throws no screen found error. – user91679 Jul 27 '16 at 14:55
  • I've added to my main post of the xorg.conf.new layout that was generated by X -configure – user91679 Jul 28 '16 at 5:39
3

I eventually managed to find my solution and fix what I was trying to get working.

Little help came from when I read this section over on Ask Ubuntu - https://askubuntu.com/questions/476681/primus-fatal-bumblebee-daemon-reported-error-could-not-load-gpu-driver

Solution:

1: Purge packages and config files

purged system of old or broken configs by removing the following.

$ sudo apt-get purge nvidia* *nouveau* bumblebee*

2: Install Nvidia drivers + extras

if you are installing nvidia driver other than nvidia-367 change that to your desired one.

$ sudo apt-get install nvidia-367 primus nvidia-settings nvidia-profiler nvidia-visual-profiler

Once installed nvidia and all it's components should be located under

64-bit:

/usr/lib/nvidia-367
/usr/lib/nvidia-367-prime
/usr/lib/nvidia-cuda-toolkit
/usr/lib/nvidia-prime-applet
/usr/lib/nvidia-visual-profiler

32-bit:

/usr/lib32/nvidia-367
/usr/lib32/nvidia-367-prime
/usr/lib32/nvidia-cuda-toolkit
/usr/lib32/nvidia-prime-applet
/usr/lib32/nvidia-visual-profiler

3:Use nvidia-xconfig:

I was suppose to use nvidia-xconfig to generate the proper xorg.conf file required to use it, but it's binary executable wasn't in it's usual place to call it from the pre-set PATH environment.

Open up Terminal and run this as root;

$ sudo /usr/lib/nvidia-367/bin/nvidia-xconfig

This should now hopefully execute and generate the proper xorg.conf file into /etc/X11/ directory. If there is still another xorg.conf file(s), make sure you find the new one, this is easily identifiable since nvidia-xconfig generates a timestamp in the new xorg.conf file which should look something like this;

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.35  (buildmeister@swio-display-x64-rhel04-01)  Mon Jul 11 23:51:45 PDT 2016

You can probably safely delete the old xorg-conf files that do not have this timestamp in them.

next open up NVIDIA X Server Settings and select NVIDIA (Performance Mode), then reboot and you should be done. If you also have the nvidia-prime-applet installed then on your next reboot you should now see the NVIDIA icon in your menu bar to show it's active.

  • Hi, I followed your answer and now I have a black screen after the reboot. What's next? – No More Hello World Nov 27 '16 at 19:12
0

Alt+F2

driver-manager

choose Nouveau driver, apply
then click on restart

Alt+F2

gnome-terminal

run these commands

sudo apt-get purge bumblebee*
sudo apt-get purge bbswitch*
sudo apt-get purge nvidia*
sudo apt-get --purge autoremove

It is necessary to upgrade to the latest kernel

sudo apt-get dist-upgrade

or via Update manager

Then run

driver-manager

again and install Nvidia drivers, this worked for me, maybe will work for you too. Good luck.

It obviously did not work out, I don't like recommending it, but would you consider adding a PPA, which I myself used to get Nvidia going?

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get upgrade

Try changing this section

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    BusID       "PCI:1:0:0"
EndSection

into this

Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

and then test X with this config file.

  • The whole point was that I don't use those nouveau drivers and use the official release ones, because I don't get full proper usage out of those unofficial open-source drivers, and to just use the official release drivers with bumblebee or something like that. I did a similar thing in Linux Mint 17. except there was not switching on/off thing, the entire graphical display just ran off Nvidia as did the software rendering, which wasn't very practical, since running the desktop as well as application rendering drained its potential. – user91679 Jul 27 '16 at 5:43
  • it is a temporary change, for you to be able to run desktop, after purging nvidia drivers as shown I reinstalled nvidia drivers with success – LinuxSecurityFreak Jul 27 '16 at 7:32
  • OK I tried what you said, but it reverts back to failing to start the desktop manager display yet again. – user91679 Jul 27 '16 at 8:18
  • Alright, it seems I have managed to get the Nvidia driver to work and the display manager running stable without it throwing errors. -- Ok so I was digging around a little more for answers on the Internet and I came across this one thing here askubuntu.com/questions/476681/… which helped me a little bit get things in order. I'll detail more in my new post. – user91679 Jul 28 '16 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy