2

I probably messed up something and I can't type tilde and brackets in my terminal. I'm on Mac OS X but I thought this has something to do with Emacs that I use just from yesterday for an online course. What can I check?

  • Are you able to type those characters elsewhere, like in the Finder? – Kusalananda Jul 26 '16 at 18:29
  • Oh yes! Tried even in editors like atom and sublime and I can type them – Ursus Jul 26 '16 at 18:31
  • Do you get other characters when you try typing tilde etc.? Does this affect only the command line in Terminal, or all applications (emacs etc.)? – Kusalananda Jul 26 '16 at 18:33
  • No characters appear if I type them in terminal or emacs. In irb (interactive ruby) alt+è gives me ? instead of squared open bracket – Ursus Jul 26 '16 at 18:37
  • Which keyboard layout do you use? I'm pretty sure this wouldn't arise on a US layout. – Gilles Jul 26 '16 at 23:40
2

You can use Emacs in the X11 environemnt. Then you can forget about the Meta-Key in default terminal.

0

I solved unchecking the "use option as meta key" in my preference's terminal. But I fear it's not a solution because I need that for emacs.

0

You should try iTerm2. It's generally better than Terminal.app. Sometimes you need to type reset to reset the terminal, it could be that too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.