0

$ httpd -S gives only the names of hosts, and the DocumentRoot is not seen. How can I see the assigned folders also?

I need like this:

NameVirtualHost *:80
<VirtualHost *:80>
   DocumentRoot /xampp/htdocs/gift
   ServerName gift.loc  
</VirtualHost>

But get like this:

VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server noelforte.com (/etc/apache2/sites-enabled/000-default:1)
0

Try with apachectl for example

apachectl -t -D DUMP_RUN_CFG

Is it showing the info you are looking for?

  • No. Just wrote 'Syntax OK' – Sonya Seyrios Jul 26 '16 at 18:58
  • Syntax OK is outputed when I type apachectl -t only. – sebastienvg Jul 26 '16 at 19:00
  • I wrote as you showed above. I don't have root right, may it influence? I don't want to edit, only to see – Sonya Seyrios Jul 26 '16 at 19:03
  • I don't think it should matter, I tried with an unprivileged user and had the same result. Can you confirm the version of apache you are running? – sebastienvg Jul 27 '16 at 13:33
  • Any other suggestions? – Sonya Seyrios Jul 31 '16 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.