0

This question is an exact duplicate of:

See this: Some websites load while others load forever in Linux Mint 18

And this: https://unix.stackexchange.com/questions/298119/is-there-anything-suspicious-in-my-ifconfig

Also don't forget about this:

ping -c 1 -s 1500 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1500(1528) bytes of data. 1508 bytes from 8.8.8.8: icmp_seq=1 ttl=58 time=13.9 ms

--- 8.8.8.8 ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 13.946/13.946/13.946/0.000 ms

ping -c 1 -s 1600 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1600(1628) bytes of data. 1608 bytes from 8.8.8.8: icmp_seq=1 ttl=58 time=14.1 ms

--- 8.8.8.8 ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 14.128/14.128/14.128/0.000 ms

ping -c 1 -s 9000 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 9000(9028) bytes of data. 9008 bytes from 8.8.8.8: icmp_seq=1 ttl=58 time=15.1 ms

--- 8.8.8.8 ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 15.158/15.158/15.158/0.000 ms

Only thing is, I changed MTU of enpxxx and ppp0 and it's now 1492 in ifconfig.

marked as duplicate by Jeff Schaller, Rui F Ribeiro, Stephen Kitt, Kusalananda, sam Jul 26 '16 at 22:04

This question was marked as an exact duplicate of an existing question.

  • this should be an edit or comment ot your previous post – Jeff Schaller Jul 26 '16 at 15:50
  • It appears you're asking why you can successfully ping with a packet bigger than your MTU... – derobert Jul 26 '16 at 16:30
1

Pinging with a larger packet than the path MTU worked because you didn't give ping options to prevent it from sending IP fragments.

With the ping I have installed and my 1500-byte MTU it'd be:

ping -M do -s 1472 8.8.8.8 works, whereas ping -M do -s 1473 8.8.8.8 gives an error. The -M do option prohibits fragmentation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.