Unity is currently the default window manager on my system, a window manager that's available for many Linux distributions, meaning this question isn't Ubuntu-specific. I have disabled the dock's autohide using debconf, but apart from that I haven't altered any of the default settings. My usage pattern is centred around the Windows key; whenever I wish to start something, whether it be Firefox, GVim, or a terminal window, I just hit the windows key, start typing the name, and hit enter when Unity guesses what it is I want.

This use means I have no need to keep anything in the launcher. Given that I only start applications using the keyboard, I only need the dock to show me currently running applications.

Naturally, my response was to simply remove everything I could from the dock, meaning all that remains is running applications.

It doesn't work though. If I remove all 'pinned' applications from the dock, the system repopulates it to the defaults on restart of Unity. I assume that Unity thinks everything being removed is either a user error or a clobbered configuration file somewhere, and as such 'repairs' it by restoring the pinned applications.

How can I suppress this setting so I can have an empty dock?

  • Did you ever solve this? – Jason C Jul 12 '14 at 21:50

This page suggests the libdconf0 package may be corrupt, and can be fixed by running this command in a terminal:

sudo apt-get install --reinstall libdconf0

This bug report suggests to me that an update might even fix the problem.

There's some additional information here on that particular issue: https://askubuntu.com/questions/49766/unity-launcher-does-not-remember-favorites

If the above doesn't help, this person (http://ubuntuforums.org/showthread.php?t=1842493#post11429491) suggests deleting the unity config folder may fix the problem. They didn't specify which folder needed to be removed, but if it's a matter of a corrupt Unity configuration, the solutions here might help:

If there is a .unity or .compiz folder in your home folder, removing those (after backing them up) may work as a last resort, although that could mess up your entire gnome/unity/compiz configuration. It might be best to back up your entire home folder first in that case.

  • Here's what I tried from your list: reinstalled libdconf0; updated to a version past the one mentioned in the bug fix report; removed all configuration files and folders I could find; reinstalled the whole of Unity; and deleted Compiz configuration using the defaults. None of them fixed the problem -_- Thanks for the suggestions though. – Louis Jan 28 '12 at 0:02
  • Just to add, do you think I should file a bug report? It's subtly different to the forgetful-settings being detailed in the above bug fix page. – Louis Jan 28 '12 at 0:11
  • 1
    @Louis did you also try unity --reset, unity --reset-icons, and gsettings reset com.canonical.Unity.Launcher favorites? Are you using Unity or Unity 2D? Because it seems that where the settings are stored differs between the two. Before filing a bug, you might want to try removing all of the applications except one to see if that sticks. It also might not hurt to ask this on askubuntu.com. – bmaupin Jan 31 '12 at 17:35
  • Out of those three I've already done the first two suggestions, but to no avail. The latter I tried just now, with the same result. I just tried Unity and Unity 2D, finding that both have the same problem. I also removed all graphical applications I've installed, which included DWM, LXDE, and Exaile. The problem remains, which is to be expected since it had this issue before I installed any of them. Thanks for the help so far though. – Louis Feb 1 '12 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.