0

I've installed TPM and am running it last and so on but none of the icons from the icon plugins are displaying correctly, nor do several other things I've added, I don't know what's going on I've tried a few fixes I found on github for issues but none of them work.

I'm not sure what's going on.

This is a link to my tmux.conf.

Here's my status bar left and right from the conf:

set -g status-left "#[fg=green]#S-: #[fg=brightblue]#{curl icanhazip.com} #[fg=yellow]#{ifconfig en0 | grep 'inet ' | awk '{print \"en0 \" $2}'} #{ifconfig en1 | grep 'inet ' | awk '{print \"en1 \" $2}'} #[fg=red]#{ifconfig tun0 | grep 'inet ' | awk '{print \"vpn \" $2}'} "
set -g status-right "[#{prefix_highlight}|#{online_status}|#{cpu_icon}:#{cpu_percentage}|#{battery_icon}:#{battery_percentage}/#{battery_remain}] %a %h-%d %H:%M:%S#[default]"

Here's what my status bar looks like as it stands:

1 Answer 1

0

Ok, for some reason tpm was thinking it had installed all the plugins I had listed, Obviously it had not, so after manually using the clean_install.sh script I re-ran the install and it worked, so now I have a properly working status bar.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .