4

To start the X server on boot, use of a display manager such as lightdm seems to be the preferred method. However, if I start X by starting the lightdm service, I get a "No protocol specified" error. If I run the same command that lightdm calls according to ps -ef:

sudo /usr/lib/xorg/Xorg -core :0 :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

(I added sudo as it doesn't start otherwise.) Everything appears to work.

A simple call to

sudo X :0

works as well.

Additional information: This is on an Ubuntu 16.04 system and I am running everything remotely via SSH (No X11 Forwarding, xorg.conf is setup for virtual monitors, one for each GPU). When starting X manually, OpenGL acceleration and everything else works (tested via DISPLAY=:0 glxgears).

  • Did you manage to fix this? I'm facing the same problem. – José Tomás Tocino Mar 15 at 12:53
  • No, sorry. We never solved this. – Joe Mar 15 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.