4

I am using akmods from RPMFusion for VirtualBox. The packages listed by rpm -qa are:

kmod-VirtualBox-4.6.4-301.fc24.x86_64-5.0.24-1.fc24.x86_64
VirtualBox-5.0.24-1.fc24.x86_64
VirtualBox-kmodsrc-5.0.24-1.fc24.x86_64
akmod-VirtualBox-5.0.24-1.fc24.x86_64

Further, the modules are built and located in the correct directory:

/usr/lib/modules/4.6.4-301.fc24.x86_64/extra/VirtualBox/vboxdrv.ko
/usr/lib/udev/rules.d/90-vboxdrv.rules

I omitted vboxguest, etc. I can manually load the modules with modprobe and it displays with modinfo:

filename:       /lib/modules/4.6.4-301.fc24.x86_64/extra/VirtualBox/vboxdrv.ko
version:        5.0.24_RPMFusion r108355 (0x00240000)
license:        GPL
description:    Oracle VM VirtualBox Support Driver
author:         Oracle Corporation
srcversion:     0D9059DC39F24CF9E36EA61
depends:        
vermagic:       4.6.4-301.fc24.x86_64 SMP mod_unload 
parm:           force_async_tsc:force the asynchronous TSC mode (int

The problem is that it will not load via systemd:

● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2016-07-24 16:09:50 EDT; 5s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 3961 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 3961 (code=exited, status=1/FAILURE)

journalctl _PID=3961 shows:

Failed to insert 'vboxdrv': Operation not permitted

And so on and so forth.

I've tried everything on the Internet but they don't seem to be related to my problem:

  • The old modules are not being loaded
  • They are not located in my initramfs
  • I will not switch to Oracle's repo because that's missing the point
  • I will not use DKMS because that's missing the point, and doesn't do anything by itself since RPMFusion doesn't do DKMS
  • I do not have SecureBoot. My motherboard does not even support it.
  • akmods --force shows Checking kmods exist for 4.6.4-301.fc24.x86_64 [ OK ] and that's it. depmods -a runs and looks like it's doing something but doesn't solve my problem.
  • I have completely wiped the packages and reinstalled them, but it doesn't fix the problem. /var/cache/akmods show that the modules are being built against the correct kernel module as demonstrated anyways, so I'm convinced the problem is related to systemd.

My NVIDIA kernel module is loading just fine.

It may or may not be related but shutdown takes forever. If I hit F12, I see "Running stop job for Building.. akmods service" and it takes a 1 minute and 30 seconds before my computer shuts off. systemd-analyze critical-chain shows thjat most of the time is spent in systemd-user-sessions.service @35.189s +178ms. systemd-analyze blame shows 13.548s akmods.service.

I've checked RedHat bug reports and have not been able to decipher them. Please try to avoid giving common solutions found in forums on the Internet because rest assured, I've tried them.

2
  • What is the output of modprobe -v vboxdrv? That will see if the module can be loaded at all, and give a clue of what is going wrong.
    – grochmal
    Jul 24 '16 at 22:13
  • @grochmal insmod /lib/modules/4.6.4-301.fc24.x86_64/extra/VirtualBox/vboxdrv.ko As I stated in my question, modprobe works fine. The issue seems to primarily be related to systemd.
    – user181277
    Jul 24 '16 at 22:47
3

Turn off the secure boot option from the BIOS settings then try to sign the driver following the steps described here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.