0

I am trying to install Zorin OS on Fujitsu Lifebook AH530. The installation runs smoothly, but when system reboots, it drops into (initramfs) shell, with the message:

ALERT~ /dev/disk/by-uuid/.... does not exist.

From the shell I checked, but there is no /dev/disk neither there is /dev/sda (or any other such device).

I am installing it without keeping Windows, and I tried with many partition options (default, default with LVM, custom partitions) but non worked and was dropped in shell every time.

EDIT: Another thing that might be relative is that the cat /proc/modules returns nothing (it's empty).

EDIT2: Another thing I noticed the version I get from uname -r from (initramfs) shell is 3.19.0-39-generic, but the actual kernel in boot directory (and /lib/modules/???/) is 4.2.0-23-generic. Is that normal? if not how can I fix this.

0

I am able to solve the problem, by running update from the live CD.

Here's how did it.

  1. boot into the Live CD
  2. Press Ctrl-Alt-F1 to get terminal
  3. sudo mount /dev/sda1 /mnt (replace sda1 to your installation root partition)
  4. sudo mount --bind /dev /mnt/dev
  5. sudo mount --bind /proc /mnt/proc
  6. sudo mount --bind /sys /mnt/sys
  7. sudo chroot /mnt
  8. apt update
  9. apt upgrade

This caused system to get new version of the kernel, and I saw that during update initramfs was updated as well as grub.

So even though I didn't found out what actually caused the issue, but luckily the update solved the problem I was having.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.