3

I just installed Linux Mint 18 on a laptop that previously had Windows 10 booting in UEFI mode. The laptop is a Lenovo g40-80.

Before, with Mint 17.3, I couldn't install Mint (it would install but wouldn't boot). Now I installed Mint 18 correctly and it works fine, but when I boot into Windows 10 I get an error saying something like.

The Boot Configuration Data for your PC is missing or contains errors

Here's the error:

Windows failed to start. A recent hardware or software change might be the
cause. To fix the problem:

  1. Insert your Windows installation disc and restart your computer.
  2. Choose your language settings, and then click "Next."
  3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer
manufacturer for assistance.

    File: \Boot\BCD

    Status: 0xc000000e

    Info: The Boot Configuration Data for your PC is missing or contains
          errors.

I tried logging into Mint (which, again, logs fine) and do a update-grub but it didn't do anything.

Since this is the manufacturer's Windows 10 install and I don't have a product key to install fresh, I tried the embedded recovery. This also didn't work! Although I got no error messages.

Right now, if I start the computer with the Windows boot manager (by pressing the a small button on the side instead of the main power button, then choosing the Boot Menu option, then the Windows boot manager) it logs on Windows, but I'd like the normal dual-boot to work, since Windows is important for work.

Anything else I should try?

EDIT

Might be related to this question

EDIT2

I tried boot-repair and it told me that the current session is in Legacy mode! Which is weird, because I'm sure that I booted Mint in UEFI mode when I started the Mint installation. Now I think this might be related to my problem but I'm still not sure how to fix this.

  • 1
    Since this is the manufacturer's Windows 10 install and I don't have a product key to install fresh There are tools that can read out the used key. You should be able to reinstall Windows from scratch with a downloaded iso using that key if the activation isn't linked to your hardware anyway and activates automatically. First thing I always did with OEM machines was formatting everything and doing a clean install. – idkfa Jul 27 '16 at 8:07
1

Boot from the original installation Windows 10 DVD ,and open the command line choosing System Restore >>> Troubleshoot >>>> Command Prompt and type the following commands:

diskpart
list disk
select disk 0
list vol

Let’s say your EFI partition is on Volume 1 (the EFI partition is using the FAT32 file system); type:

sel vol 1
assign letter=k
exit

Next step you need to repair the boot record:

cd /d v:\EFI\Microsoft\Boot\
bootrec /fixboot

Recreate the Boot Configuration Data (BCD):

ren BCD BCD.old
bcdboot c:\Windows /l en-us /s v: /f ALL

Restart your computer

  • I don't have the original installation DVD (didn't come with one, so I couldn't test this) – TomCho Jul 25 '16 at 15:21
0

I solved it by re-installing Linux Mint making sure to boot the installation DVD in EFI mode and to choose the EFI partition in the drop-down menu during the installation. Apparently the cause of this issue is the installation of Mint in EFI mode but without selecting the EFI partition in this step.

The first boot worked perfectly, so I consider this problem to be solved. However, after booting on Windows it made the Linux option disappear. But this appears to be another issue so, one problem at a time.

  • This is more of a comment than an answer. – idkfa Jul 27 '16 at 8:04
  • 1
    Regarding your comment that windows made linux disappear. If you install Windows after Linux you need to reinstall grub afterwards. Windows overwrites everything. It's easier if you install Windows first, then Linux. – idkfa Jul 27 '16 at 8:13
  • @idkfa Yes, but I never uninstalled/installed windows. It was always there; I just downsized one partition and intalled Linux. I know about this issue. Just logging into windows after installing Linux was enough to overwrite the Linux entry! Also, I made a comment out of this because this is what actually solved the problem. This way it's well-documented for future use in the community. – TomCho Jul 27 '16 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.