2

I've usually been using Debian Squeeze, as I've never really had any reason to go after the latest & greatest, and if I wanted to, I always had backported packages to rely on.

However, my new laptop (an Asus U31SD) has an Atheros chip (id [1969:1083]) which is not supported in the kernel until 2.6.38.

So I tried downloading the latest weekly build, which happened to install KDE for some reason. The last three daily builds also installed KDE, and as far as I know, I am not selecting any meta packages during the install that would install it (Just "core", "laptop", and "SSH Server").

Is there any particular reason this is happening? I was always under the impression that Debian came with GNOME...


Edit: I've been getting my ISOs here:

  1. http://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/ (specifically CD1, and not the KDE version at the bottom)
  2. http://cdimage.debian.org/cdimage/daily-builds/daily.new/ (netist versions for amd64)
  • 1
    Any reason for not installing the 3.* kernel series from Debian Backports (if that's easier for you)? – Teresa e Junior Jan 23 '12 at 14:39
  • Trying a debian squeeze ISO causes my laptop to not have any connection to the internet at all, as there is no ethernet driver. I suppose I could create a list of packages from another computer and upgrade the kernel that way, but not having done it before, I am averse to doing so. – Julian H. Lam Jan 23 '12 at 15:22
  • I tried downloading yet another ISO from the daily builds. This one installed Debian with no desktop environment whatsoever. Perfect. – Julian H. Lam Jan 25 '12 at 4:56
2

Eventually, the daily ISOs reverted back to using GNOME as the desktop environment.

0

I believe you should be able to just pass the desktop=gnome parameter at the boot menu and to get what you want.

  • Hi Mike, thanks for the comment. I ended up with an install ISO that installed no desktop environment whatsoever, so I just installed gnome right on top. – Julian H. Lam Jan 26 '12 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.