6

I just installed Mint 18 as a virtual machine using VMware 12. I have the problem that I can't install vmware-tools. At first I tried to install open-vm-tools as is recommended by Mint, but it didn't work, so I uninstalled it and then tried to install the default vmware-tools, but it can't be installed.

enter image description here

18

Forget VM tools, use:

sudo apt-get install open-vm-tools open-vm-tools-desktop

Then do a full restart and check that the client screen will resize when the host window resizes.

  • 1
    +1: This worked for me with Linux Mint 19. – Arun Saha Oct 7 '18 at 23:39
  • This worked for me on Linux Mint 19.1 XFCE x64 – user Feb 23 at 1:19
2

You need to sudo or su at root first before running vmware-tools-install.

0

I installed Linux Mint 19.1 (Tessa) onto VMware ESX 5.5 in a virtual machine, allocating 30g HDD, 2g memory, (resource manager shows Mint using 10g HDD and 900k memory).

After installing the VMwareTools (to get a bigger screen), I got a message saying that "Cinnamon desktop has crashed, would you like to restart it". If you say Yes, then it crashes again in few seconds, if you say No, then it reverts to a simpler desktop (not sure what).

So, I did some hunting and found "open-vm-tools-desktop" and installed it, (after disabling VMwareTools at startup), and now Cinnamon stops crashing.

Here's what you do - (you need to install the package in the "/" root directory as root) -

  1. sudo su
  2. cd /
  3. sudo apt-get install open-vm-tools open-vm-tools-desktop
  4. reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.