0

I have an archlinux 4.4 lts kernel. For some reason I did not allow gdm to start automatically at boot. When I'm logged in tty and start the gdm with command systemctl start gdm the gdm starts and the gnome login screen appears while it is pointless to bring the login screen because I start it from the tty already logged in, isn't it! Now the question is, why gdm ask for me to login? is it the bug of gdm or simply default behavior? How can I prevent gdm to ask for login? * please ignore grammar mistakes.

0

gdm tis the graphical login processor.

If you want a logged-in session run startx

gdm asks you to log in because it doesn't know who you are.

  • I think I ask about gdm, how to change the gdm behavior? startx is not an option here – user137124 Jul 23 '16 at 10:34
  • gdm is hard to change, I've tried. the documented auto-login options only partially work. – Jasen Jul 23 '16 at 10:38
  • Can you share what you have tried!? – user137124 Jul 23 '16 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy