2

I finished the installation of Debian Jessie 8.5, but the system doesn't detect the wireless. My wireless is hidden, have password with wpa psk/wpa2 psk and I am using the Xfce desktop environment.

ip a:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 28:d2:44:c1:02:85 brd ff:ff:ff:ff:ff:ff

lsusb:

Bus 003 Device 002: ID 8087:8000 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0bda:b728 Realtek Semiconductor Corp. 
Bus 001 Device 004: ID 13d3:5727 IMC Networks 
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 062a:4102 Creative Labs 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

lspci -knn | grep Net -A2:

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Lenovo Device [17aa:b736]
    Kernel driver in use: rtl8723be
  • 1
    It may be that your firmware is missing : some devices need a proprietary firmware, which will not be automatically installed without you knowing and meaning it. Could you edit your question adding the output (in the terminal) of the commands ip a to see whether the device can be configured, lsusb and lspci to see the model in case it is not. In the last two, look for Ethernet controller. – Vincent Nivoliers Jul 22 '16 at 11:03
  • 1
    Please add the output of lspci -knn | grep Net -A2 – GAD3R Jul 22 '16 at 12:20
  • @Sona , To get a good question ,Please , Clic on edit unix.stackexchange.com/posts/297585/edit and add the output of lspci -knn | grep Net -A2 . – GAD3R Jul 23 '16 at 16:41
  • lspci -knn | grep Net -A2 02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723] Subsystem: Lenovo Device [17aa:b736] Kernel driver in use: rtl8723be – Sona Jul 24 '16 at 9:46
2

You need to install firmware-realtek

Binary firmware for Realtek wired and wireless network adapters

This package contains the binary firmware for some Ethernet adapters with the RTL8111/RTL8168 chips supported by the r8169 driver; and wireless network cards with the RTL8188, RTL8192, RTL8712, RTL8723 and RTL8821 chips supported by the r8192_pci, r8192s_usb, r8712u, rtl8188eu, rtl8192ce, rtl8192cu, rtl8192de, rtl8192se, rtl8723ae, rtl8723au, rtl8723be and rtl8821ae drivers.

The needed driver is :rtl8723be

1) Connect throught ethernet

Add non-free repo to your sources.list:

nano /etc/apt/sources.list

then add the following lines:

deb http://ftp.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie main contrib non-free

Update and install realtek drivers

apt-get update && apt-get install firmware-realtek

If your connexion keep disconnecting type the following command :

echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

2) Without internet connexion:

Download firmware-realtek_0.43_all.deb , using your archive manager extract rtl8723befw.bin from /lib/firmware/rtlwifi/rtl8723befw.bin and copy it to /lib/firmware/rtlwifi :

cp rtl8723befw.bin /lib/firmware/rtlwifi/

Reload the driver :

modprobe -rv rtl8723be
modprobe -v rtl8723be

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.