9

I have a windows 10 host OS where I have installed vmware workstation 12 player. I have an Xubuntu as a guest OS (virtual machine).

The complication is: the text is too small in guest OS and almost unreadable.

The steps that I have already taken to rectify the problem are given below:

  1. I have already installed vmware tools (which is confirmed by hovering on Manage -> Reinstall vmware tools).
  2. I have tried to manually set the resolution in the vmware before starting the virtual machine (by manually changing it to 640 by 480 and then to other settings).
  3. In vmware workstation 12 player, i cannot see the stretch the guest OS but I have tried to stretch the guest desktop in the guest OS.

Note: I am using DELL XPS 15 with 4k UHD.

Any help in this regard is highly appreciable. If I am unable to explain anything please let me know, I can provide more details.

  • This is a Windows / VMWare issue. I had the same issue on the same type of laptop. I think the Windows setting I used to avoid this issue is here, reply #10. – mazs Jul 22 '16 at 9:54
  • I have read that post to put a check in the shortcut's property of the vmware but in my case nothing changes. The text in guest OS is way too much small. – stalbaig Jul 22 '16 at 10:09
  • it worked for me with the same setup (dell xps + vmware workstation pro). after applying the changes, you have to restart vmware, and the virtual machine as well. – mazs Jul 22 '16 at 11:10
13

It worked for me too on a HP Spectre 4k laptop (windows 10):

  • Right click on the vmware player icon on the desktop shortcut and click properties.
  • Move to compatibility tab.
  • Check the option "override high DPI scaling behavior. And select the System Enhanced for Scaling performed by:.
  • Apply and restart VM.

It should work. Got a result after 5 hours spent on the web.

  • You are the best. This answer fixed a year old problem of mine. Thanks. – taesu Dec 30 '17 at 7:24
  • for me the steps were (again windows 10): after compatibility tab, I had to click Change High DPI settings – Asqan Jun 16 '18 at 22:09
  • 7
    While scaling is perfect with this trick, unfortunately my mouse cursor is no longer aligned with its visual representation... I'm using VMware Player 14 on Windows 10 and the guest OS is Ubuntu 18.04.1. – François Beaune Jul 30 '18 at 12:13
0

All popular DEs for Linux have settings, that allow user to override default DPI. This setting is related to fonts, but affects everything. Set DPI to something bigger, then standard 96, and, after reboot, all programs will be zoomed. Also modern GUI toolkits have ability to zoom themes and icons, but only by integer multipliers like 2x, 3x, 4x. You can combine this two zooming technologies to get best results for your screen.

-2

When trying to fix the Guest OS fonts sizes you can:

One way:

Set the installation as windows 10-64-bit and choose type as windows guest, then proceed normally.

Another way:

Customize within the guest by:

  1. Right clicking the mouse to open change desktop background
  2. Enter fonts menu and set your font size above 20, depending on your screen.

Then you can go to themes and customize the mouse pointer scale and default scaling mode for icons and desktop apps, etc.

Lastly you can click on taskbar and change scale in properties.. etc

protected by Community Jun 16 '17 at 10:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.