2

I currently have a problem with Wireless LAN on Linux Mint 17.1.

I can't enable WLAN, when trying to enable it, it disables immediately.

Here some commands which I already tried out and found by googling myself around.

$ lspci -nn | grep "Network controller"
02:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6200 [8086:422c] (rev 35)

I then found out that the correspondig driver I is iwlwifi.

$ rfkill list
...
3. phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

As far as I read, Hard blocked means, that my WLAN hardware switch is turned off. But when I play around with the corresponding key (fn+f8) then only the Soft blocked value changes.

In one thread I found that when I execute

$ modinfo ath5k | grep "nohwcrypt"
parm: nohwcrypt:Disable hardware encryption. (bool)

then I should try executing

$ sudo modprobe ath5k nohwcrypt

though I don't really what this does and it did not change anything.

In the BIOS the Wireless LAN is enabled and Windows was installed before and there it worked as well so I don't think that the hardware is not working and it is a software problem.

Does anybody know how to proceed?

EDIT:

Output of

$ lspci -knn | grep Net -A2
02:00.0 Network controller [0200]: Intel Corporation Centrino Advanced-N 6200 [8086:422c] (rev 35)
        Subsystem: Intel Corporation Centrino Advanced-N 6200 [8086:422c]
        Kernel driver in use: iwlwifi
  • Please add the output of lspci -knn | grep Net -A2 – GAD3R Jul 21 '16 at 20:51
1

Download the right driver from here : iwlwifi-6000-4.ucode.

Copy the firmware to your /lib/firmware:

cp iwlwifi-*.ucode /lib/firmware

Load the driver:

modprobe -r iwlwifi
modprobe iwlwifi
rfkill unblock all

Edit

Install build-essential and linux headers

sudo apt-get install build-essential linux-headers-$(uname -r)

Download iwlwifi-6000-ucode-9.221.4.1.tgz from here

wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-6000-ucode-9.221.4.1.tgz
tar -zxvf iwlwifi-6000-ucode-9.221.4.1.tgz
cd iwlwifi-6000-ucode-9.221.4.1
cp iwlwifi-*.ucode /lib/firmware

Download backport

wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.13.2/backports-3.13.2-1.tar.gz
tar -xzvf backports-3.13.2-1.tar.gz
cd backports-3.13.2-1
make defconfig-iwlwifi
make
sudo make install

Unload and load driver:

rmmod iwlwifi
modprobe iwlwifi
  • Hi! Thanks for your answer. I downloaded the driver and loaded it the way you pointed out. But it did not change anything. When I switch off the WLAN and then unblock all then only the softblocked value changes. – Chris Jul 22 '16 at 10:20
  • Please add the output of uname -a i will edit my answer – GAD3R Jul 22 '16 at 12:25
0

The ath5k driver is not related to your hardware. Trying anything with it will not fix your problem, since it is a driver for atheros hardware, not Intel.

It may be that there's a second hardware switch on your laptop. Look for a slider or something of the sort. If you can't find that, check your BIOS; I've seen cases where the 'hardware' rfkill switch was really a BIOS setting, before. Finally, check if the firmware-iwlwifi package is installed. This package contains the necessary firmware which the kernel needs to upload to your wifi card, without which it cannot work. It may be that the driver will mark the hardware rfkill switch if it doesn't have firmware (although this would be weird).

  • Hi! thanks for your answer. When I type dpkg -s firmware-iwlwifithen I get that the package was not found or that no information is available. When I use sudo apt-get install firmware-iwlwifi then the package is not found. Am I doing it incorrectly? – Chris Jul 21 '16 at 21:31
  • You may need to enable the 'multiverse' repositories. Unfortunately, the iwlwifi firmware is nonfree software, which means it's not in Ubuntu's main repositories (and therefore not in mint's, either) – Wouter Verhelst Jul 21 '16 at 22:36
  • I added the trusty multiverse repositories but still can't find firmware-iwlwifi. Another suggestion? – Chris Jul 22 '16 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.