I've been trying to get this program to work on my Raspberry Pi for the past two days and I've gotten to step 6 which says, "At this point, you should be able to modprobe v4l2loopback".

When I ran the command at the bottom of the Github page, nothing happened. I've never worked in a Linux environment before and don't even know what modprobe means. Can a guru take a look at the link and tell me if there is more to modprobing than just running the command ./v4l2lepton /dev/videoX?

2 Answers 2


You're missing a link to the page in question, but even without that link I can tell you that the page is simply telling you to run modprobe v4l2loopback. The modprobe command is a way of inserting a new kernel module into the running kernel without having to rebuild the entire kernel and/or reboot the machine. Chances are you won't be able to successfully run ./v4l2lepton /dev/videoX until after you've run modprobe v4l2loopback and posibly another command to insert the module and create the video device entry in /dev.

  • I've added the link, thanks for letting me know. Also, when I run modprobe v4l2loopback I just get an error that says FATAL: Module v4l2loopback not found. and I'm not sure why this is happening because I have already copied the .ko file into /lib/modules like the repo said to do.
    – sgmm
    Jul 21, 2016 at 15:01
  • Can you try "insmod /path/to/module.ko"? insmod is more limited in what it can achieve, compared to modprobe, but it allows loading modules by their filename to test in this situation.
    – user179983
    Jul 21, 2016 at 15:07
  • Generally, a modprobe failure like that means you're getting the module name wrong (4-ell-2 versus 4-one-2, possibly) or that it's not readable (file permissions).
    – John
    Jul 21, 2016 at 15:07
  • @JakGibb I ran the command insmode /lib/modules/v4l2loopback and it told me that the command was not found. Is there a apt-get for it?
    – sgmm
    Jul 21, 2016 at 15:31
  • Did you run insmod or insmode? insmod is the lower level program called by modprobe so it will be there.
    – user179983
    Jul 21, 2016 at 15:31

I've justed tested this on a Raspberry Pi I had lying around, and it worked perfectly.
Perhaps you missed a step with the instructions, or were using an older kernel version to begin with.

Here are the steps I took which worked.
You didn't mention which OS you were running on the Pi, but I'm using a fresh install of the latest version of raspbian (2016-05-27 with kernel 4.4).

[root]#: apt-get install bc libncurses5-dev

[root]#: wget https://raw.githubusercontent.com/notro/rpi-source/master /rpi-source -O /usr/bin/rpi-source && sudo chmod +x /usr/bin/rpi-source && /usr/bin/rpi-source -q --tag-update

[root]#: rpi-source

[root]#: git clone https://github.com/umlaeute/v4l2loopback.git

[root]#: cd v4l2loopback/

[root]#: make

[root]#: cp v4l2loopback.ko /lib/modules/4.4.11+/

[root]#: modprobe v4l2loopback

Now to confirm the module is actually loaded:

[root]#: lsmod |grep v4l2loopback
v4l2loopback 27026 0
videodev 172779 1 v4l2loopback

  • I did all that and even got the same confirmation that you did. But when I run the command ./vl2loopback /dev/videoX I just get this error message: Failed to open v4l2sing device. (No such file or directory). I should point out that I copied the file into /lib/modules/ and didn't add the 4.4.11+ at the end because when I tried to do that it gave me an error.
    – sgmm
    Jul 22, 2016 at 15:04
  • Well that's good, it means the original issue of the module not being able to be loaded is now resolved. As for the new issue, I'd assume that where the instructions state /dev/videoX they are expecting you to replace the 'X' with a number that relates to your video device. Try running: ls /dev/vid* to list the devices detected, and then run your command again with that device. e.g.: ./v4l2sing /dev/video0
    – user179983
    Jul 22, 2016 at 16:19
  • Crystal, in your comment above you wrote: "./vl2loopback /dev/videoX" instead of "./vl2lepton /dev/videoX" (note also that "X" needs to be a number for the device, 0,1,2,3 etc.) Dec 3, 2016 at 18:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .