3

Im trying to enable a Kernel-module in my Yocto image, as I have done this already before with an older installation where this works properly.

This is the command I'm running:

$ bitbake linux-variscite -c menuconfig

And then I've got this error:

$ ERROR: Unable to spawn terminal auto: ... ... (Translated to English) The option "--disable-factory" is not supported in this Version of gnome-terminal.

AFAIK yocto tries with "disable-factory" to open a new instance of a gnome-terminal.

My Host-System is a Debian Jessie with Mate-Desktop environment. I've also tried to run bitbake from a KDE-Konsole, bit then I've get the same error, so I assume yocto calls "gnome-terminal" direct.

What can I do? Any suggestions?

Thanks!

Regards, Thomas

2 Answers 2

4

Last time I had to do this I overrode the default gnome-terminal, which I don't have, with xterm. Assuming you have installed xterm then edit your local.conf file, eg with

echo 'OE_TERMINAL = "xterm"' >>conf/local.conf
1
  • Works for me on Exception: OSError: [Errno 13] Permission denied; ERROR: Function failed: do_menuconfig
    – firo
    Mar 19, 2018 at 4:41
1

I faced a very close problem with Yocto. I use to configure and compile Linux kernels with a Yocto tool-chain through a ssh X forwarded session. The computer on which I run Yocto is installed with a regular Ubuntu-16.04. If I use the menuconfig command directly on this computer everything is going well and the menuconfig window comes up into a gnome-terminal.

    bitbake -c menuconfig -f virtual/kernel

But as soon as I use the same command line into a ssh session the same gnome-terminal never shows up:

ERROR: Unable to spawn terminal auto: Execution of '.../linux/0.1-r0/temp/run.do_terminal.13867' failed with exit code 1: Option "-t" is no longer supported in this version of gnome-terminal.

Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Could not connect: Connection refused

My solution was to edit the terminal.py file into the poky directory as :

sources/poky/meta/lib/oe/terminal.py and add the dbus-lanch.

 line 56 : command = 'dbus-launch gnome-terminal -t "{title}" --disable-factory -x {command}'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.