0

I have installed XYMon server successfully, but I can't get the client information to show. It took me a while to figure out, but if you add a host to the server that doesn't have the client, it still shows some things like conn/ssh/info, but nothing like cpu/disk/mem.

I have found it to be REALLY hard to find any good documentation, troubleshooting steps or anything. The installation of the client seems extremely simple.

On Ubuntu 14.04 >>

apt-get install xymon-client

Only one question during installation

IP of XYMon-Server

But I can't get anything to show in the server!

The closest I have come to debugging is

On Server :

@xymon:/var/log/xymon$ cat alert.log

2016-07-20 21:31:52 ->  Could not connect to Xymon [email protected]:1984 (Connection refused)

@xymon:/var/log/xymon$ cat xymonlaunch.log

2016-07-20 22:00:27 Cannot open env file /usr/local/xymon/server/etc/hobbitserver.cfg - No such file or directory
2016-07-20 22:00:27 Loading hostnames
2016-07-20 22:00:27 Loading saved state
2016-07-20 22:00:27 Setting up network listener on 0.0.0.0:1984
2016-07-20 22:00:27 Setting up signal handlers
2016-07-20 22:00:27 Setting up xymond channels
2016-07-20 22:00:27 Setting up logfiles
2016-07-20 22:10:27 Cannot open env file /usr/local/xymon/server/etc/hobbitserver.cfg - No such file or directory

On Both Client & Server I found this Error :

@xymon:/var/log/xymon$ cat xymonclient.log 
No LSB modules are available. - Repeated for ever...

There was nothing more useful in client logs.

Install XYMON Config :

sudo apt-get install -y xymon
sudo cp /etc/apache2/conf.d/xymon /etc/apache2/conf-available/xymon.conf
sudo ln -s /etc/apache2/conf-available/xymon.conf /etc/apache2/conf-enabled/
sudo ln -s /etc/apache2/mods-available/authz_groupfile.load /etc/apache2/mods-enabled/
sudo ln -s /etc/apache2/mods-available/rewrite.load /etc/apache2/mods-enabled/
sudo ln -s /etc/apache2/mods-available/cgi.load /etc/apache2/mods-enabled/
sudo ln -s /var/lib/xymon /var/www/html/xymon
sudo nano /etc/apache2/conf-available/xymon.conf

Replace the below 2 lines with the bottom ONE line. (All instances)

#Order allow,deny
#Allow from localhost ::1/128
Require all granted

2 Answers 2

2

Based on This page from XYMon regarding Clients not reporting I figured it out. While it gives the problem, I couldn't get the solutions there to work.

On Client :

cat /etc/default/xymon-client | grep CLIENTHOSTNAME

Must Match on Server :

/etc/xymon/hosts.cfg

1.2.3.4 CLIENTHOSTNAME 

If it doesn't match EXACTLY then >>

"Xymon only cares about the hosts that are in the hosts.cfg file, and discards status-reports from unknown hosts"

1
  • Note, I was able to change CLIENTHOSTNAME and then change hosts.cfg and it worked. Commented Jul 21, 2016 at 14:37
1

You can also try to run sudo dpkg-reconfigure xymon-client on your client and insert the exact hostname as you wrote it in your hosts.cfg on your server.

1
  • This is the "ubuntu/debian" way to fix it, but its always good to know what "dpkg-reconfigure" is doing!, I expect most people using xymon have both Debian and RHEL based clients, and /etc/default/xymon/ is import to know, but def +1 for the simple debian answer Commented Mar 15, 2018 at 11:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .