2

After edited the /etc/security/limits.conf file to set the nofile parameter to unlimited, server got hanged . Can't login in via ssh. Tried to take console, issue with console. Will reboot of the VM will solve the login issue ?

3

Running ulimit -n unlimited as superuser on Linux says: Operation not permitted. You need to boot into single user mode and fix your limits.conf back and specify some reasonable value, because Linux denies unlimited NOFILE.

2
  • Curious. Will single-user mode ignore limits.conf?
    – roaima
    Jul 22 '16 at 23:00
  • 2
    Depends on how init system handles this. If it starts sulogin with ulimits from limits.conf then I think this is disastrous, but can be easily fixed with rebooting into plain single user with init=/bin/sh kernel parameter, which I always use. Then you will not be affected by bad limits.conf.
    – user140866
    Jul 23 '16 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.