2

First it repeats this error many times:

Lvmetad is not active yet, using direct activation during sysinit
Volume group "mint-vg"not found
Cannot process volume group mint-vg

Than it shows:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
    - Check rootdelay= (did the system wait long enough?)
    - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/mapper/mint--vg-root does not exist.
Dropping to a shell!

And then it goes into BusyBox (iniframfs)

I also tried an older kernel but it give the same thing.

I remember installing a "systemd" update before this happened. Edit: I am using Linux mint 18 for the live and main drive on this main computer with the problems as described by the way. Does anyone knows what should I do from here?

Edit1:
I tried this solution:

Missing root VG, dropped to an initramfs shell. [SOLVED] From LVM LVS,now I know that my vg is "mint-vg" and my root LV is "root". I changed it in mounted /boot/grub/grub.cfg and restarted the computer.

But now it repeats this error many times:

Lvmetad is not active yet, using direct activation during sysinit
Volume group "mint" not found
Cannot process volume group mint

Than it shows:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
    - Check rootdelay= (did the system wait long enough?)
    - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/mapper/mint-vg-root does not exist.
Dropping to a shell!

Does anyone know how to update grub and initramfs?

Edit2:
I thought the new error above is due to the the additional dash between "mint" and "vg", so I changed the volume group name to "mint_vg" via KVPM GUI application. Nope, I still get same error as above just that the mapper name and volume group name changed.

Edit3:
I do not what I am doing right now, I installed boot repair on a live disk, decrypt and mount my main system, and run boot repair. Now the system have a newer grub I think and a newer kernel... I tried all three kernels including the new one and they all give the same results as both.

Edit4:
blkid's uuid for my root is different in etc/fstab and etc/crypttab. I changed those files in live disk and still the same errors on reboot.

Edit5:
Some of the naming above is wrong, changing it from /dev/disk to /dev/mapper

Edit6:
I am progressing well with Peter's answer (downgraded systemd! I changed some things in my /etc/host of my live drive to match my main drive's /etc/host) but I tried Peter's last three command line and it gave me these problems:

root@mint / # grub-install /dev/sda
Installing for i386-pc platform.
grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).
root@mint / # update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.4.0-31-generic
cat: /proc/cmdline: No such file or directory
root@mint / # update-grub
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
root@mint / # 

I also tried forgoing these lines and try to boot my main drive again; didn't work.

Edit7:
According to Peter, I forgotten the line

for d in dev proc sys; do mount -o bind /$d /mnt/root/$d; done

It gave me syntax error at do. Oh well, according to him I just have to break them down which I did:

sudo mount -o bind /dev /mnt/root/dev
sudo mount -o bind /proc /mnt/root/proc
sudo mount -o bind /sys /mnt/root/sys

afterwards I follow the rest of the steps in his answer to the point where I have problems in Edit6

grub-install /dev/sda seems to work:

Installing for i386-pc platform.
Installation finished. No error reported.

update-initramfs -u on the other hand gave me some messages that might be errors, I'll check these messages out after this edit:

update-initramfs: Generating /boot/initrd.img-4.4.0-31-generic
cryptsetup: WARNING: invalid line in /etc/crypttab for luks-8cb0dfcf-f4c8-47a2-aede-7fae0217797e - 
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.

I think the biggest problem comes at update-grub:

Generating grub configuration file ...
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
Found linux image: /boot/vmlinuz-4.4.0-31-generic
Found initrd image: /boot/initrd.img-4.4.0-31-generic
Found linux image: /boot/vmlinuz-4.4.0-28-generic
Found initrd image: /boot/initrd.img-4.4.0-28-generic
Found linux image: /boot/vmlinuz-4.4.0-21-generic
Found initrd image: /boot/initrd.img-4.4.0-21-generic
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your device.map.
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
done  

If anyone know solutions for problems above, please let me know.

Edit8:
For good measure, here are /etc/fstab and /etc/crypttab

Fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
UUID=9434a2fe-8f66-494d-a098-2aaa8b51a811 /     ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
#UUID=97fff05b-8e15-4a6b-ba91-08babab89e8e /boot           ext2    defaults        0       2
#/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
#UUID=02270177-d1a5-41bf-9b1c-f8f46fe22bb3  none swap sw 0 0
#Move /tmp to RAM
tmpfs /tmp tmpfs defaults,noexec,nosuid 0 0
/dev/disk/by-uuid/89d3985d-93b9-4193-bc7e-ada76afba948 /mnt/89d3985d-93b9-4193-bc7e-ada76afba948 auto nosuid,nodev,nofail,x-gvfs-show 0 0
#UUID=97fff05b-8e15-4a6b-ba91-08babab89e8e  /boot   ext2    defaults    0   2
UUID=97fff05b-8e15-4a6b-ba91-08babab89e8e   /boot   ext2    defaults    0   2

Crypttab:

sda5_crypt UUID=9434a2fe-8f66-494d-a098-2aaa8b51a811 none luks,discard
#cryptswap1 UUID=02270177-d1a5-41bf-9b1c-f8f46fe22bb3 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64
luks-f1e0883c-d8c1-4ec1-b5e7-8a9918ea0d5e UUID=f1e0883c-d8c1-4ec1-b5e7-8a9918ea0d5e /etc/luks-keys/luks-f1e0883c-d8c1-4ec1-b5e7-8a9918ea0d5e nofail  

Edit9:
Changed 9434a2fe-8f66-494d-a098-2aaa8b51a811 into 8cb0dfcf-f4c8-47a2-aede-7fae0217797e in both files above and now after excuting update-initramfs -u I only have W: mdadm: /etc/mdadm/mdadm.conf defines no arrays. error message, will be focusing on that now. The invalid message (Edit7) is gone.

Edit10:
I gave up, reinstalling everything is much easier than going through this crap. I will never install level 4 or 5 updates again.

  • when you're at the shell, does vgs or ls /dev/mapper/ list the volume groups? – Peter Jul 20 '16 at 10:50
  • @Peter vgs: not found and Ls /dev/mapper only shows control – user1602020 Jul 20 '16 at 11:00
  • Is there really no one could help me? That is really depressing, it's been over 24 hours since it happened and it's getting bleak. – user1602020 Jul 21 '16 at 3:17
  • it's not a simple issue... normally this never happens. You have to do something wrong to break it normally (eg. using grub2 and blocklists, or replace the distro kernel with one too new or too old for your lvm version). But systemd does things wrong for you... is this one of them? I have no idea. I avoid systemd because of things like this (things that happen without reason and without explanation, which is not unique to systemd either). And for prevention, you could have made a separate /boot, but it might be too late for that now. – Peter Jul 21 '16 at 7:46
  • Also I find distros using dracut will do things like this too, but I think mint isn't one of them. – Peter Jul 21 '16 at 7:46
0

So since you are getting desperate, here's a temporary/dirty solution...

  • boot rescue media
  • mount filesystems and chroot into it, eg.

    mkdir /mnt/root
    mount /dev/mapper/mint--vg-root /mnt/root
    mount /dev/sda1 /mnt/root/boot # example if you have separate boot
    for d in dev proc sys; do mount -o bind /$d /mnt/root/$d; done
    chroot /mnt/root /bin/bash
    
  • then try some fixes... I suggest downgrading the systemd version or other files (see the history of your upgrade in /var/log/apt/history.log) ( following is an example on ubuntu 16.04...I don't have a mint to look at)

    $ apt-cache policy systemd   
    systemd:
    Installed: 229-4ubuntu6
    Candidate: 229-4ubuntu6
    Version table:
    *** 229-4ubuntu6 500
            500 http://de.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
            100 /var/lib/dpkg/status
        229-4ubuntu4 500
            500 http://de.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    
    $ apt-get install systemd=229-4ubuntu4
    
  • and then in case you need to update this, eg. because some software you changed would have generated it differently, regenerate the boot stuff (make sure to fix fstab if it is not fixed already...):

    grub-install /dev/sda
    update-initramfs -u
    update-grub
    

And final note, your output says /dev/disk/vg-... and I don't believe that is right. It should say /deg/mapper/vg-... with "mapper", not "disk". I would fix that in fstab, but I'm unsure what sort of hackery has placed that there... I assume you did not manually do it, so I'm unsure if it's a problem.

  • Sigh, problematic dependencies issues when installing systemd=229-4ubuntu4.... It say system : Depends: libsystemd0 (= 229-4ubuntu4) but 229-4ubuntu7 is to be installed E: Unable to correct problems, you have held broken packages Tried to update and install it: sudo apt install libsystemd0=229-4ubuntu4 but there a lot of temporary failure resolving 'archive.ubuntu.com' issues... – user1602020 Jul 21 '16 at 9:06
  • ok well then the rescue system didn't set up network... you should do that manually, eg. ip a add x.x.x.x/y dev eth0 ip r add default via x.x.x.x and check that /etc/resolv.conf is filled in, otherwise nameserver x.x.x.x in there too – Peter Jul 21 '16 at 9:11
  • and btw, you could also just do the fstab, grub and initramfs stuff alone to test without any package changes... since it's quick – Peter Jul 21 '16 at 9:13
  • Sigh, I'm not good at command line, this is really a problem for me. I think I might still do what you suggested but should I also consider sysvinit? Linux mint 18 here btw. – user1602020 Jul 21 '16 at 9:34
  • As much pain as systemd can be, switching from systemd to an unsupported init system might be harder for you. – Peter Jul 21 '16 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.