I have a really weird problem with my laptop ASUS K53SV. It has two graphics card (Intel + Nvidia) and nvidia optimus, but I'm actually using just the intel one. My operating system is Fedora 16. When I connect my external screen, a Samsung 2033HD, I have problems with it. It's shaking, like it had some refresh rate problems. The actual resolution is 1600x900, refresh rate 60Hz.

I tried to change the VGA cable, but the problem is still the same.

The point is that the same monitor works without any problem at the same resolution with my netbook (an ASUS 1215P with Fedora as well and an intel graphic card), and the same laptop doesn't have any problem if I connect it to a different screen (samsung 24 inch 1920x1080).

I just tried to boot with two different distributions: with Fuduntu I have the same problem (I suppose because it's based on Fedora), while with Ubuntu the screen is working fine at 1600x900.

The following is my xrandr output. I already tried without success to change the refresh rate.

Screen 0: minimum 320 x 200, current 2966 x 900, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1600x900+1366+0 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900       60.0*+
   1280x1024      75.0  
   1440x900       59.9  
   1280x800       74.9     59.8  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

I can't believe it, what should I do/try?

  • Can you provide the output of xrandr? Try issuing:xrandr --output VGA1 --auto to enable external output. This, assuming your external monitor is named VGA1. See xrandr output. – user13742 Jan 22 '12 at 17:28
  • I added the xrandr output to my question. The command you suggested doesn't change anything. Thanks anyway! – javanna Jan 22 '12 at 18:55

I had a similar problem ... in my case the flickering of the monitor was because of the difference in electrical grounding of the laptop and of the monitor, in most of the cases laptops don't use grounding.

So the obvious solution would be also to use the monitor without grounding. Either plug it in a nongrounded socket or cut the ground wire from the power cable of the monitor ( in most cases - yellow-green-ish cable )

Have fun and let me know if it worked

  • I had this happen with my desktop once when I connected a TV capture card to the cable. Turned out the cable in the apartment I was in had 48v 60 Hz leakage that contaminated the ground plane on the PC. It just gave a distorted image at 60 Hz refresh though, and a 10 Hz beat wobble at 70 Hz refresh. – psusi Jan 31 '12 at 2:05
  • Thanks for your feedback and sorry for my delayed reply. I kind of fixed it installing bumblebee, but I'm still having some weird problems. I just think Optimus is evil :) – javanna Feb 16 '12 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.