2

Server: Ubuntu 16.04 Server, x64, no internet connection

I have LXD installed but am having trouble getting an image to that server to use as a baseline for containers. I have tried two options so far, with failed results.

1) Export image (Xenial)(meta.tar and rootfs.tar) from machine with internet and burn to cd. Import works fine, but when starting the newly built container it fails with the log showing

lxc_utils - utils.c:safe_mount:1692 - Operation not permitted - Failed to mount proc onto /usr/lib/x86_64-linux-gnu/lxc/proc

2) Download the meta and root tarballs from the linuxcontainers.org repo and burn them to a cd. Importing gives error that metadata.yaml does not exist (which looks to be true).

What other options do I have? I have 16.04 server on a disc if creating an image from that is a possibility.

0

Update: Tried the exact same 2 methods with the same files on a newly created VM and BOTH worked just fine. Issue must be in my VM, therefore I will be migrating to a new (working) VM.

Edit: The root cause actually lies somewhere in xen-guest-tools that provide additional functionality while running on Citrix XenServer (which in this case was). Pre-installation, containers worked fine. Post installation, I got the errors above.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.