1

I'm trying to set up a system where the user can't change the desktop and panels that I have set up for them. I chose xfce because I read there is a kiosk-mode but I cannot make that work at all. I'm using xfce 4.10, is the kiosk mode still around? I followed the instructions on https://wiki.xfce.org/howto/kiosk_mode, focusing on the [xfce4-panel]. Is there something else I need to do to enable this?

I'm not the only one with this problem and another solution seem to be to alter /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml to inlude the line . This has helped some people, for instance https://askubuntu.com/questions/74205/how-do-i-prevent-a-user-from-customizing-the-panel-in-xubuntu.

It did work for me in the beginning, but as my panel has grown, it does not work anymore... I'm using the panel as a program launcher, and I'm guessing it has something to do with adding external programs, but I've tried to sort this out without any luck. What happens is that after adding the locked/unlocked setting and logging out and back in, I'm greeted with the "choose default panel" message. This seems to be the behavior for other people having the same problem as well.

Am I missing something? What is the relation between the files in ~/.config/xfce4, /etc/xdg/xfce4 and /etc/xfce4? Should for instance the xfce4-panel.xml be the same?

My working solution atm is to simply disable the right mouse button, but that is not a reasonable solution since there are programs which depends on the right mouse button. Is it possible to enable the button again for some programs (and still not allow the user to right click the panel while the program is open)? Can I intercept the right mouse button, see which program it is calling and only let some through?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.