3

I bought an xps laptop with a 4k screen. Because of this, the font-size of my text consoles (Ctrl+Alt+[F1-F6]) are quite tiny. So I tried to change the resolution by editing /etc/default/grub like it is adviced by many tutorials. Right now it looks like this:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

#GRUB_TERMINAL=console

#GRUB_GFXMODE=640x480

#GRUB_DISABLE_LINUX_UUID=true

#GRUB_DISABLE_RECOVERY="true"

#GRUB_INIT_TUNE="480 440 1"

# Changes -------------------------------------------------------------------

# Set resolution of text consoles
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=1024x768

This settings doesn't change the resolution of my text consoles. When I use the attribute nomodeset (GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset") the text consoles are displayed with the specified resolution, but then my GUI is realy slow, has the same resolution and I even can't log into my account.

So how do I get it work (use specified text console resolution, different GUI resolution and GUI not broken)?

I run Ubuntu 15.10 and has a Nvidia GeForce GT 750M. I am new to Linux so please keep it simple :) Thanks in advance.

  • how about just setting the console font to a larger size using setfont? – h0tw1r3 Jul 18 '16 at 21:14
1

I have a similar problem, and I found that setfont works fine. Try:

$ setfont Uni2-VGA28x16

The list of available console fonts are under: /usr/share/consolefonts (for my ubuntu install)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.