1

every time when I issue shutdown command, laptop is powering off, but after 5 second turn on again without pressing power on button.

I found that when my wifi adapter is off, shutdown command works properly, it just powers off the laptop and doesn't turn on unless I have not pressed power button.

So maybe there is something wrong with wireless drivers?

HP Probook i5-3230M , according to lspci - wifi adapter is Ralink rt3290.

dmesg -x --ctime --level=warn --level=err --level=crit --level=alert --level=emerg

pastebin.com/wHaNwStt

4

I have had to fix it by turning on wifi before shutdown. Yes, it's not ideal and it does not fix a firmware bug on ACPI, but it's beter than nothing.

/etc/systemd/system/wifimanager.service

[Unit]
Description=Wifi manager which stops radio signal
DefaultDependencies=no
Before=shutdown.target reboot.target halt.target

[Service]
Type=oneshot
ExecStart=/usr/bin/wifimanager start

[Install]
WantedBy=halt.target reboot.target shutdown.target

/usr/bin/wifimanager

#!/bin/bash

start() {
  rfkill block 0
}

stop() {
  rfkill unblock 0
}


case "$1" in
  start)
    start
    exit 0
    ;;
  stop)
    stop
    exit 0
    ;;
esac

And then just add it to startup

systemctl enable wifimanager.service
0

From searching online, there seems to be many potential causes for this, including on the Mint Forums.

Try running the following command:

sudo shutdown -P now

If this shuts down your machine properly, then it may be an issue with compatibility with your physical power button (if that is what you are using to shut down your computer when you have the issue).

In that case, try:

sudo apt-get update && sudo apt-get install laptop-mode-tools

This will install laptop-mode-tools which may install enough laptop config settings to allow Mint to poweroff elegantly. After install, choose laptop mode.

If that does not work, then set ACPI to not route IRQs. A captured IRQ that the kernel doesn't release could cause BIOS to always cycle rather than power off. Using you choice of text editor as superuser (in this case I used vim), add "acpi=noirq" to GRUB as follows:

sudo vim /etc/default/grub

Find the line starting GRUB_CMDLINE_LINUX_DEFAULT and add acpi=noirq to the end between the quote marks so that it resembles:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noirq"

Then run:

sudo update-grub

This change cannot take effect until after at least one full reboot cycle, so don't expect it to power off your machine the first time. If problem remains, then reverse procedure and take out the change. No point in diminishing functionality if it doesn't do anything.

Lastly, if any of the above possible fixes do not work, take a look at your BIOS power management settings, including (but not limited to) ACPI and APIC as this may be the cause. Alternatively, you can try updating you BIOS which may also provide a fix.

source_1 source_2

  • Thanks for your reply. shutdown -P now - does not help. I have opened grub file but the GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash" already. so, I didn't issue update-grub command. Sorry, but your advices do not help much. – CEO at Apartico Jul 18 '16 at 16:15
  • Alright, I appreciate your feedback. I'll continue looking for possible solutions. Have you tried shutting it down while the Laptop is on battery power? Also, can you please add the output of running lspci to take a look at your hardware? – Paradox Jul 18 '16 at 16:23
  • Also, please try installing laptop-mode-tools as this seems to have fixed it for quite a few people. – Paradox Jul 18 '16 at 16:29
  • Thank you, okay, shutting down on battery power does not affect anything. Issue is still reproducable. – CEO at Apartico Jul 18 '16 at 17:06
  • Few minutes till I provide lspci... I had no chance to paste output of lspci command here so I just provide a link where you may find that information: pastebin.com/NyMR9T9R – CEO at Apartico Jul 18 '16 at 17:10
0

From your question it looks to me like you have "wake on LAN" or something similar set in the BIOS (or on the interface). That setting means that the net interface will still be listening on the net and when it receives a packet addressed to it, it wakes up the CPU. What you need to do is go through the BIOS settings and see if anything looks related to this problem. Sorry I can't be more specific, but all BIOS setup systems are a little different and I'm not familiar with that specific machine.

  • Thanks MAP, It's already off "Wake-on-Lan" and also I was able to disaply another hidden settings "Wake-on-lan Battery mode". They both disabled - unfortunately, it does not solve the issue. – CEO at Apartico Jul 19 '16 at 7:33
0

Linux Mint 18.1:

My problem was that my new PC hanged at unsystematic moments at shutdown/power off. I had to push the on/off button for several seconds (also mechanical power off). After I changed a setting in the UEFI-Bios the problem was gone:

Open the UEFI/Bios:

Advanced-> Powermanagement-> EuP-setting disabled

Exit by saving the settings

then restart your computer and everything is OK

Succes

  • No chance to check it out but if someone can confirm that this helps - please, upvote the answer. – CEO at Apartico Mar 11 at 21:55
0

I had the same problem, whenever I tried to shutdown the system it would restart after 3 to 5 seconds. My system is built on an Intel NUC with mint 18.1 installed and kernel 4.4.0-53

I have just fixed my problem completely by updating my kernel to 4.4.0-78.

So far so good... I will update this if I hit any further problems.

If you are unsure what kernel version you are using go to system info in the start menu.

You can update using update manager-->View-->Linux Kernels.

I would recommend researching the problems you can encounter when changing the kernel you are using, as it can cause more problems than you solve. backups of important files is always recommended.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.