3

I'm trying to enable middle mouse button scrolling on my dell precision with 4 buttons on the trackpad and a trackpoint with 3 buttons thing. However it does something weird with how the button events are received. Device 11 can send mouse move events, but does not send button presses, while device 10 will send all of the events.

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=10   [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=12   [slave  keyboard (3)]

The libinput Scroll Method is set to button on the PS/2 mouse, but that device will never see button 2 go down for it. How can I get the events to be sent properly? I was thinking that the buttons on the trackpad can be re associated to the mouse. However, I have no idea on how to get this to work.

I tested the scroll events using xinput test <device-id>.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.