7

After fresh installation of Linux Mint 18 64-bit, when I try to suspend screen goes black and system does not suspend (and power led stays on).

Preinstalled kernel with Linux Mint 18 is 4.4.0-21

I am using laptop TOSHIBA-SATELLITE-L50-B, with graphics Intel+AMD:

$ inxi -Fxz

Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Jet PRO [Radeon R5 M230] bus-ID: 09:00.0
           Display Server: X.Org 1.18.3 drivers: ati,radeon,intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.01hz

I've found solution and wanted to share in case someone else bumps into this.

1 Answer 1

9

I've solved this issue by installing new linux kernel "4.5.2-040502-generic" following this guidelines:

https://askubuntu.com/questions/761758/ubuntu-16-04-lts-cannot-suspend-fails-on-suspending

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1574125/comments/26

Install new kernel (4.5.2):

cd /tmp

wget \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.2-wily/linux-headers-4.5.2-040502_4.5.2-040502.201604200335_all.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.2-wily/linux-headers-4.5.2-040502-generic_4.5.2-040502.201604200335_amd64.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.2-wily/linux-image-4.5.2-040502-generic_4.5.2-040502.201604200335_amd64.deb

sudo dpkg -i linux-headers-4.5*.deb linux-image-4.5*.deb

Reboot your system and try if suspend works.

In case something goes wrong with new kernel (4.5.2) reboot your computer and select Advanced options for Linux Mint 18 Cinnamon 64-bit in boot menu, then select your old kernel (4.4.0-21).

6
  • 3
    Thank you so much! This worked perfectly! I followed the steps above and suspend seems to be working great
    – gabbar0x
    Aug 4, 2016 at 19:42
  • Thank you so mutch. This is freaky thing. I lost a couple days to find this TRUE answer.
    – James M
    Sep 9, 2016 at 9:56
  • Glad to see that this helped you
    – nexayq
    Sep 18, 2016 at 8:45
  • 1
    Just wanted to mention that 4.5.2 had issues on my machine (Lenovo T440p) but 4.7.5 is working great and fixed the suspend/resume issue.
    – Joseph
    Dec 19, 2016 at 2:03
  • 1
    Your answer made clear (unlike other online sources) that you need to download the headers_all package, and not just the headers_generic and image_generic. I am testing 4.10.17 (latest 4.10 build) because of it. Thank you for that. Jul 19, 2017 at 4:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.