3

I have yet another laptop which is a casualty of the proprietary Nvidia driver. I would like to do CUDA development on the laptop (Dell Precision 5510 with Quadro M1000M and 4k display), so I want the proprietary driver.

I have tried for several hours now, even reading through this, and I just don't know how to configure xorg when it won't autoconfigure. I used nvidia-xconfig to set my xorg.conf initially, then I had to add a BusID setting to the Device section in order to find the card. Now, startx runs without errors (and I can verify things are actually working), but it's like it's only showing on a ghost screen. I can run DISPLAY=:0 xrandr remotely and I get a 8x8 virtual screen with no outputs:

Screen 0: minimum 8 x 8, current 8 x 8, maximum 16384 x 16384

I get the following chunk of Nvidia-related output in my xorg log file, with a couple of suspicious NULL values:

(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 16 22:35:15 2016
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"

...

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling 2D acceleration
(II) NVIDIA(0): NVIDIA GPU Quadro M1000M (GM107GL-A) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 2097152 kBytes
(--) NVIDIA(0): VideoBIOS: 82.07.82.00.23
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(II) NVIDIA(0): Validated MetaModes:
(II) NVIDIA(0):     "NULL"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(WW) NVIDIA(0): Unable to get display device for DPI computation.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
(--) Depth 24 pixmap format is 32 bpp
(II) NVIDIA: Using 12288.00 MB of virtual memory for indirect memory
(II) NVIDIA:     access.
(WW) NVIDIA(0): ACPI: AC power state information is not available under
(WW) NVIDIA(0):     /sys/class/power_supply/ , nor under
(WW) NVIDIA(0):     /proc/acpi/ac_adapter/
(II) NVIDIA(0): Built-in logo is bigger than the screen.
(II) NVIDIA(0): Setting mode "NULL"
(==) NVIDIA(0): Disabling shared memory pixmaps
(==) NVIDIA(0): Backing store enabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled

Here is my current xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.35  (buildmeister@swio-display-x64-rhel04-01)  Mon Jul 11 23:51:45 PDT 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "LaptopBuiltin"
    ModelName      "eDP1"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    #BusId          "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
0

If you're saying that you previously had no xorg.conf, and that you created it with that content, then I would start simpler. You don't need all that.

All you should need to utilize the nvidia driver is:

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
EndSection

You might also need the following for OpenGL:

Section "Files"
    ModulePath "/usr/lib64/opengl/nvidia"
EndSection

(exact value depends on your system paths)

If that still doesn't work, please post the entire xorg log.

  • Thanks for helping! I tried that xorg file, and it was the same effect as before I put in the BusID: it says it doesn't find any nvidia devices, and then my xserver works but I don't have any GLX support (though in the log I can see it tried to do GLX). I also didn't find any opengl folder except in something related to LibreOffice. On the other hand, if I specify the BusID, I get the same situation as mentioned above, with GLX working but no visible X server. Would you like the with- or without-BusID xorg log file? Or both? – rexroni Jul 17 '16 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.