0

I tried to install mcu8051ide on Mac OSX, but I faced to some problem of package dependency. Please see the error message below.

$ mcu8051ide --check-libraries
MCU 8051 IDE v1.4.10

    Checking libraries...
        1/9 Checking for library BWidget
            Library present ... YES
            Version 1.8 ... YES
        2/9 Checking for library Itcl
            Library present ... YES
            Version 3.4 ... YES
        3/9 Checking for library md5
            Library present ... YES
            Version 2.0 ... YES
        4/9 Checking for library Tk
            Library present ... YES
            Version 8.5 ... YES
        5/9 Checking for library img::png
            Library present ... NO !
            Version 1.3 ... NO !
        6/9 Checking for library tdom
            Library present ... YES
            Version 0.8 ... YES
        9/9 Checking for library Tcl
            Library present ... YES
            Version 8.2 ... YES

    RESULTS:
        Number of fails: 1
        PROGRAM WILL NOT RUN, please install the missing libraries

I tried to install the missing package by command:

$ brew install homebrew/dupes/tcl-tk

But it didn't seem to work. Then I tried to install it manually by went to tkimg website and download it. I unzip it and got several *dylib files. Honestly, I don't know how to deal with these kind of thing. Anyone has some more simple idea to get this done?

  • Has there been any updates? I have tried placing the Img-Darwin64-1.4.6 folder in different Libraries to no avail. – Axel Jacobsen Apr 21 at 19:23
0

I'm also working on accomplishing the same thing. To install img::png, you started the right way with downloading and unzipping. What you should do is place the files in a location where Tcl can find them. I put them in ~/Library/Tcl/Img-Darwin64-1.4.6, and it found them correctly.

However, the IDE still doesn't run correctly since it makes several assumptions that it's running on X11, which is not the case for native Tcl on OS X. I'll update if I manage to work around all the issues. An alternative would be to just run in in a Linux VM or container, but that would be less nicely integrated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.