1

CUPS on Linux found our brand new office printer, a Canon iR-ADV C5535F, part of the imageRunner Advance C5500 series. I downloaded the PPDs for Mac OS X and told CUPS to use it, which CUPS allows you to do in the course of add new printer.

I can set things up, I can send test pages to the printer, but they don't appear on the printer's LED panel under my name. On Windows, the document I printed appears on the panel under my name (in the form windows-user/WINDOWS-DOMAIN), and I then have to use the panel in order to start printing.

I tried to set the printer's operation policy from default to authenticated (under set default options), added myself to the list of allowed users. I even tried to enable the security feature (under set default options), which is an option I don't think our printer has, as it is disabled in the settings on a Windows machine that work with this printer.

All to no avail. I can print test pages, they show up in the "completed jobs" page as "completed", with no error.

Any idea how to get the printer to print on Linux with CUPS?

Here is a screenshot of the "completed", yet unprinted jobs.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.