2

I have been using UGET in order to download what I need. I've had no problems with it until I tried downloading a file with 4.5 GB of volume. 3.6 GB of it has been downloaded and UGET stops working and gets killed unexpectedly. I checked for volume deficiency (Baobab 1.8.2 on Ubuntu-Mate 14.04) and viewed no problem with the capacity. The others files of 550 MB of volume continue to be downloaded but the problem with the larger file still exists. How would it be possible for me to continue and end the download of 4.5 GB file without any interruptions?
Thank you very mech in advance.

1
  • what linux were you using? and how did you install uget? – user32012 Jan 5 '18 at 14:08
1

The very simple solution is now discovered. The crash occurred in uGet because of the fact that I had changed the download preferences so that the program would use aria2, but didn't notice that aria2 does not get installed by itself in the time of installation of uGet (the very big problem when people migrate from windows to unixish systems).
Therefore, I fixed the problem by installing it as so:

sudo apt-get install aria2

5
  • 1
    I'm glad you solved your issue but to be fair, you shouldn't have changed your settings to a plugin you weren't aware of whether you had or not. Plugins typically are not provided during installations for any project. – Michael Tunnell Dec 29 '16 at 17:29
  • 1
    Yes sir, you are absolutely right.It truly seems I neglect some very simple facts only because I had gotten used to the Windows environment where most of the time everything gets installed by itself and not demanding the user to know much about how software works. I am in fact very happy that I have started using Unixish environments. – Tower Dec 30 '16 at 0:41
  • 1
    I had a similar problem without the program exiting - but with error on any download. You should mark your own answer as definitive. – user32012 Jan 5 '18 at 14:06
  • @MichaelTunnell - I had the impression that uget comes with aria2. Is that true at least when installed from ppa in ubuntu? – user32012 Jan 5 '18 at 14:08
  • 1
    @cipricus no. aria2 is an optional package so the user needs to manually install it. Linux & BSD versions of uGet does not need aria2 to accomplish most tasks. Windows and Android doesn't handle proper dependency management so it has to be included by default, whether it is used or not. – Michael Tunnell Jan 7 '18 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.