0

I recently bought a Lenovo Thinkpad Edge 15 (Model: 031925U) on Ebay. The machine came with Windows 7 Pro 32 bit installed. I replaced the HDD with a 240GB Samsung 750 Evo. With a 2.4Ghz i3 370M and 8GB of RAM, the Thinkpad should be able to run almost any Linux fine.

I checked the memory and the SSD and both are fine. Lenovo (http://support.lenovo.com/us/en/), Newegg, and Amazon indicate support for 64 bit operating systems on this computer.

I've tried running live and installing 32 and 64 bit Lubuntu, 64 bit Ubuntu, and 64 bit Kali with no avail. A couple times, I've been able to run Kali and Lubuntu live, but I've never been able to replicate this and both quickly froze up/crashed while in use.

Ubuntu says that my computer is certified to run 12.04 LTS (http://www.ubuntu.com/certification/hardware/201011-6828/), but I've had no success with that either.

The laptop uses integrated graphics, and I've tried using a monitor and/or the "nomodeset" parameter.

I've used Win32 Disk Imager, Rufus, and DD imaging from a Mac on 2 different flash drives (both with no bad sectors) and with burned disks.

The only clue I have is that when I run Kali in "failsafe live" I get a hangup with what looks to be my wireless card, and I get "rcu_sched kthread starved for ###### jiffies" and an error code in hexadecimal (which I have no idea how to interpret). I've done Google searches, and nothing has come up. After grub on all other options I get either a completely black screen or a blinking white cursor (and I'm not able to type).

Thanks in advance.

2

I ran Memtest86+ (memtest.org) which revealed problems in my RAM. I isolated the problems to one of my 4GB sticks, which I removed and found that everything now works fine (although I still use the "nomodeset" boot parameter).

I hadn't tried this earlier because mdsched.exe (Windows memory diagnostic) said the RAM was all fine. The giveaway that the RAM wasn't fine, however, was ironically when I tried to install Windows 10 and got the rare "kernel_security_check_failure" error and had my laptop shut down.

  • I know this is old, but thank you for reporting back with the solution. Hopefully it helps others. Also, please click the tick on the left to mark your solution as solved. Cheers! – Sparhawk May 5 '18 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.