5

Background: I have a PC with two HDMI1.4 outputs and 4k monitor that allows Picture-By-Picture display from two HDMI sources. A single HDMI1.4 connection between the computer and the monitor is limited to 30hz. With 2x 1920x2160 outputs it is possible to get 4k at 60hz

When doing this, there are two outputs and each is treated as its own monitor. This causes problems:

  • Fullscreen applications, e.g. games or video players are only “fullscreen” on half the screen because it looks like two physical monitors (from the computers point of view)
  • maximizing windows only maximizes on one (½) monitor

Is it possible to set up xrandr so that there is a virtual 3840x2160 screen, and then set up each monitor to show a part of it. E.g. monitor 1 displays the left half and monitor 2 displays the right half. Applications would only see the virtual screen and "see" a resolution of 3840x2160, even for maximized windows.

I'm using KDE if it makes any difference.

  • (I will paraphrase to see if I grok what you say) Did you say you have a monitor (just one), that has two hdmi inputs, and that this monitor can only operate at its full potential, if it pretends to be two monitors (one for each hdmi). And xrandr is configuring it to be a unified screen of 2 monitors, with multi monitor support for maximisation. But this multi monitor support for maximisation, is not what is needed in this case. – ctrl-alt-delor Jul 14 '16 at 22:33
  • Note on X11 terminology: Display = keyboard + pointing device + one or more screens, screen = a visual containing one or more monitors a window does not move between screens, monitor = the device that you display things on (windows can be dragged to another monitor of the same screen, on the same display). You do not see multi-screens much, as a program must decide which one to use, multi-monitors is more common. – ctrl-alt-delor Jul 14 '16 at 22:41
  • Some window managers do not support the feature that is presently annoying you. It may be possible to turn off in kde. If not then try another window manager. I think fvwm does not have it. – ctrl-alt-delor Jul 14 '16 at 22:51
2

I guess KDE may have something in it's settings to control this behavior. But if not, then you might try this

xrandr --output HDMI-0 --auto --output HDMI-1 --auto --{right,left}-of HDMI-0
0

I managed to work it out, xrandr has a VIRTUAL1 output. Through trial and error i worked out how to use it:

  1. Generate the modeline:

    cvt 3840 2160
    Modeline "3840x2160_60.00"  712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync
    
  2. Add the mode to xrandr:

    xrandr --newmode "3840x2160_60.00"  712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync
    
  3. Set the mode on VIRTUAL1:

    xrandr --addmode VIRTUAL1 3840x2160_60.00
    
  4. Set display1 to clone VIRTUAL1 (in my case HDMI1):

    xrandr --output HDMI1 --same-as VIRTUAL1
    
  5. Then place HDMI2 right of HDMI1:

    xrandr --output HDMI2 --right-of HDMI1
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.