0

So here's the deal; I was reading the man page for xorg.conf when I decided to edit /etc/X11/xorg.conf to try some of the flags listed in the 'SERVERFLAGS' section. When I opened the file in vim, I found it to be empty (or nonexistent), so I added one line to the file. I believe it was Option "DontZoom" "True"

I don't think think the syntax was correct because after rebooting x wouldn't load, giving me error messages about not being able to find a screen and Option "DontZoom" "True" not being valid. (I'm sorry I can't give the exact error messages) I tried generating a new xorg.conf with the X -configure command and replacing the old with the new, but that didn't work either.

What actually fixed the problem was removing xorg.conf entirely, so I'm wondering why just having a configuration file seems to prevent x from working.

I am running Linux Mint 17.3

  • If no configuration file exists, Xorg will use defaults for everything, which for most users is all they need. Once you create a configuration file, you have to take care of making it work. Since you wrote yourself that it gave an error, your line was obviously not correct, thus Xorg failed to load. – Jan Henke Jul 14 '16 at 9:18
  • I understand that the config file I wrote was broken, but what I don't get is why the generated config file didn't work? Wouldn't it be generated with default settings? – user151768 Jul 14 '16 at 9:24
  • No, as soon as you create an own config file, there is no default configuration any more. – Jan Henke Jul 14 '16 at 9:51
1

When you supply an xorg.conf file, this is the complete configuration. You can't just add one option, you have to supply all mandatory parts, including declaring the input and output peripherals. It's common for programs to start with sensible options and allow them to be overridden by a configuration file, but in the case of Xorg, supplying a configuration file erases the default options.

Saving the output of X -configure and using this as a configuration file should be equivalent to running X with no configuration file. Since you didn't provide the content of the configuration nor the logs, I can't help you as to why this didn't work for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.