1

As the topic says:

How to tell intel graphics to use my custom EDID file?

  • Doesn't seems to be related to UNIX or Linux – Mongrel Jul 14 '16 at 6:22
  • xorg is related to unix or linux, and it allows you to specify a custom EDID file for the monitor. – cas Jul 14 '16 at 6:28
  • Same issue with intel over here superuser.com/questions/1145585/… – malat Nov 14 '16 at 12:55
1

Assuming you're talking about X, you can add a CustomEDID option to the Monitor section of your /etc/X11/xorg.conf. For example, I have the following in xorg.conf on my mythtv box:

Section "Monitor"
    Identifier "LG 42LD560"
    VendorName "GSM"
    ModelName "LG TV"

    Option "UseEDID" "True"
    Option "CustomEDID" "DFP-1:/etc/X11/LG-42LD560.edid.bin"
EndSection

I did this years ago and I can't remember where i got the edid file from. I think I may have extracted it with get-edid from the debian package of read-edid (I very vaguely recall something about getting a corrupted edid in X but it was OK if fetched from a VT before X started)

  • Yes, thats exactly what I want to do. I already have the EDID binary for my monitor but have heard that intel drivers might not support custom EDID's like NVIDIA and AMD does. At the moment I use my custom EDID with a NVIDIA card under Debian, but want to take that old Nvidia card out and use the onboard Intel graphics. – Rimfire Jul 14 '16 at 7:31
  • 2
    I doubt CustomEDID apply to Monitor section... – malat Nov 14 '16 at 12:54
  • Where do you think it would apply? for the mouse? your doubt means little in the face of several years of actual experience that X worked (and still does) correctly with my LG TV using a custom edid file in the Monitor section and didn't without it. It means even less when you take into account the fact that the CustomEDID option is specifically intended for use within the Monitor section. – cas Nov 14 '16 at 17:28
  • 1
    I can confirm what malat said: both UseEDID and CustomEDID must be in the Device Section. Intel ignores UseEDID while CustomEDID is totaly broken in my braswell. – elvis.dukaj Mar 21 '17 at 9:21
0

The one that worked for me :

Section "Device"
   Identifier  "Device0"
   BusID       "PCI:00:02:0"
   Option      "LVDS-1" "MonitorLVDS1"
   Option      "DP-1"   "MonitorDP1"
   Driver      "intel"
   Option      "CustomEDID" "DP1:/etc/X11/edid.bin"
   Option      "UseEDID" "true"
EndSection

see full problem and solution : Second monitor not recognized - xorg.conf file [resolved]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.