0

I have tried to boot both ubuntu and arch on my iMac (21.5-inch, Mid 2010). Both seem to boot, for example ubuntu makes its little bongo noise, and I can type zsh commands when arch boots. But the problem is that nothing is displayed on the screen.

When I boot arch or ubuntu, apart from a bit of text at the beginning of the boot, right before the screen goes blank. The welcome to arch linux with the green [ ok ]s doesn't show up. However, if I wait a while, about the time it takes to boot into the zsh shell, and type reboot, or shutdown -h now, nothing shows up on the screen, but the commands work, and my mac reboots or shuts down.

I have a pc laptop with arch installed (it doesn't have UEFI though), and it seems like my mac screen goes blank when my pc screen would go blank and then the text would reappear a little smaller and better fit to the screen. My mac is El Capitan (10.11) if that makes any difference. I've tried booting with and without a partition ready for linux.

Is there any way to fix this, or is a mac from 2010 too old or something like that? Any suggestions are welcome.

  • Arch does not have a GUI in the install media. In general, the older the hardware you get the best driver compatibility in linux. Also, consider structuring your question, it is very hard to read (and understand). – grochmal Jul 13 '16 at 19:17
  • Yes I know that arch doesn't have a gui installer, thats why I said I installed it on my laptop. The problem is that NOTHING shows up on the screen. – Vityou Jul 13 '16 at 19:41
  • Can you attach an external monitor to the Mac and try rebooting? – Thorbjørn Ravn Andersen Jul 13 '16 at 21:37
  • The only monitor I have is a tv, which uses HDMI, and my mac doesn't have a HDMI port. – Vityou Jul 13 '16 at 21:41
  • Most tv's have multiple input ports but not all. Note that DVI is compatible with HDMI so you can use the mini-DVI port with a suitable adapter with your tv. – Thorbjørn Ravn Andersen Jul 13 '16 at 21:46
0

I was able to solve the problem by pressing alt, when the mac boots (like usual), but instead of running arch, I pressed e, and added nomodeset at the beginning of the line that showed up. Then pressed enter to boot. After installing arch linux, I had to add that kernel parameter to refind, my boot manager, to use nomodeset whenever I booted to the Arch Linux I installed on my hard drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.