I'm trying to SSH from Debian (Jessie, installed as chroot environment in Chrome OS) to Arch on the same network, and I keep getting an error saying the connection was refused because of a public key error.

  • 3
    Post the text of the error.
    – jc__
    Jul 12, 2016 at 14:54
  • 1
    Could you also add the output of ssh -v arch_ip?
    – clk
    Jul 12, 2016 at 14:54

1 Answer 1


Option 1

Enable password authentication on Server (your computer running arch-linux)

Edit the SSH configuration file on the server to allow password authentication.

[user@arch]$ sudo nano /etc/ssh/sshd_config

PasswordAuthentication yes

ChallengeResponseAuthentication yes

Use your favorite text editor instead of nano, such as vim. To use vim, once it opens the file, hit i to switch to insert mode make your edits then press esc to leave insert mode and type :wq and hit enter to write changes and quit.

Note: sudo is not part of the initial installation of arch-linux. As an alternative login to root with su.

Now if key authentication fails you will be prompted to enter your password for the user account on the arch computer.

Option 2

Generate key and send to Server

[you@debian]$ ssh-keygen
[you@debian]$ ssh-copy-id user@arch-hostname

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .