0

Our OS is CentOS 5.4.

I run into this metadata file does not match checksum issue when I tried to sudo yum update and searching for a solution online, I read this post https://www.centos.org/forums/viewtopic.php?t=17781 and didn't so carefully tried two commands given by AlanBartlett

rm -fr /var/cache/yum/*

yum --disablerepo=\* --enablerepo=base,updates check-updates

Then I realized I have made some mistakes.. when I tried sudo yum update, I got the following error.

http://xx.xx.xx.x/install/rocks-dist/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: Rocks-5.3. Please verify its path and try again

I can actually read the http://xx.xx.xx.x/install/rocks-dist/x86_64/repodata/repomd.xml file through vim but when I tried to copy it, it says the file doesn't exist.

Now I'm stuck with this yum error. Could anyone suggest some remedy to fix it?

  • What mistakes did you make? What happens if you clear all yum metadata and then run yum update again via yum clean all --enablerepo="*"; yum update – doktor5000 Jul 27 '16 at 14:19
  • tried and got the same error – user2157668 Jul 28 '16 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.