1

In the process of trying to fix an issue, I accidentally deleted /sbin/sysctl when I was intending to delete /etc/sysctl.conf.

When I run sysctl I get the error that says

The program 'sysctl' is currently not installed. You can install it by typing:
sudo apt-get install procps

When I try both install and upgrade it says procps is already the newest version. I've also tried removing procps and reinstalling it but I get this error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libegl1-mesa : Depends: libgbm1 (>= 7.11~1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Is there a way for me to just get the sysctl file from this package? Is there a fix for the error when I try to remove procps so that I can make it work that way?

If it matters, I'm on Linux Mint 17.3 Rosa with Ubuntu 14.04

4

You can use the --reinstall flag to apt-get

apt-get --reinstall install procps
  • That exactly did the trick. – elemjay19 Jul 11 '16 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.