2

I use a Retina MacBook Pro. I run Linux in virtual machines for development work.

I occasionally use the Linux GUI directly in the virtual machine, but most of the time I ssh (with the -Y parameter) from the Mac terminal to the box and run Eclipse and Firefox, for example, form there. This launches the Mac X-Windows server - used to be X11.app and now XQuartz.

My Linux GUI is always in normal resolution - whether in the VM or in the Mac X-Windows app.

What can I do to make it work in Hi-DPI mode?

Depending on the project, I can use Oracle Linux, CentOS, or Ubuntu (using the default/most popular desktop).

Similarly, depending on the project, I can use VirtualBox or VMware Fusion.

2

If you have VMware Fusion installed on your Mac one solution could be going to the selected Virtual Machine Settings and check both Accelerate 3D Graphics (Which requires VMware Tools installed on that virtual machine) and Use full resolution for Retina display (To enable Retina display support in selected virtual machine) in Display Setting.

enter image description here

BTW, Here's a useful link about HiDPI Mode in Mac OS X to get more information on it.

0

I think you can use Parallels for Mac, it seems that they support High-DPI resolution. In this article of their KB, they talk about the windows support but I think it should work also for Linux: http://kb.parallels.com/114700

  • Aah. The third option. :( I take it this is to do with the kind of 'hardware' the virtual machine presents to the guest OS? – Vihung Jul 13 '16 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.