I am running Ubuntu 10.04 LTS on a Samsung n150 netbook. I have bought a vodafone pay-as-you-go mobile broadband dongle. It is a Huawei device.

I have *usb_modeswitch* installed. I installed betavine from betavineUbuntuLink. The program loads but displays that no device is detected. I tried to use Sakis3G from sakis3Glink, using both the free and full versions, and all I get is a message that it failed to connect. I tried to create the mobile broadband connection by right clicking the connection manager and setting it up from there but the connection is never registered or displayed. When the computer is booted with the usb dongle it shows on the desktop as a mounted device, and when unmounted and re-inserted it does not appear on the desktop again, but does appear in Places as VMB_10.2.102.30707_RP171.

This usb dongle did not come with a CD for installation on Windows. In Windows, the software installed automatically from the usb device. So I believe that a further complication with this relatively new device is that it gets loaded as a CD. I tried a method of going to gconf-editor to uncheck the automount and autorun and see if the usb switching will work there after (I did a reboot), but this did not help.

When I boot the computer with the dongle it is shown on the desktop and places. When it is removed and re-inserted it shows up in places only. A green light flashes and occasionally a blue one as well. I ran lsusb after removing and re-inserting the usb dongle, which shows that the device is found:

alex@alex-laptop:~/programFiles/MATLAB/bin$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0a5c:219c Broadcom Corp. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 12d1:14d1 Huawei Technologies Co., Ltd. 
Bus 001 Device 005: ID 0ac8:c33f Z-Star Microelectronics Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I then ran dmesg | tail to get the last kernel reports:

alex@alex-laptop:~/programFiles/MATLAB/bin$ dmesg|tail
[14373.720099] usb 1-7: new high speed USB device using ehci_hcd and address 8
[14373.997592] usb 1-7: configuration #1 chosen from 1 choice
[14374.182751] scsi6 : SCSI emulation for USB Mass Storage devices
14374.184812] usb-storage: device found at 8
[14374.184825] usb-storage: waiting for device to settle before scanning
[14379.184566] usb-storage: device scan complete
[14379.185273] scsi 6:0:0:0: CD-ROM            Vodafone CD ROM (Huawei)  2.31 PQ: 0 ANSI: 2
[14379.197689] sr0: scsi-1 drive
[14379.197986] sr 6:0:0:0: Attached scsi CD-ROM sr0
[14379.198192] sr 6:0:0:0: Attached scsi generic sg1 type 5

It can be seen how the usb dongle device gets seen as a "Vodafone CD ROM (Huawei)" which I assume is the root of the troubles for betavine and sakis3g. I believe that the usual scenario is of seeing it as a drive and switching to broadband device and not as CD ROM and making that a mobile broadband device, but I could be wrong.

Is there a course of action to be recommended to get this to work? Are there any alternative tests to perform to diagnose the exact problem?

UPDATE: on the back of the usb modem it says "Model: K3770, HSPA USB Stick, FCC ID: QISK3770"

UPDATE 2: On Ubuntuforums I found a thread, link to Unbuntu forum, and a post by foxy123 contained critical information. "Enter the APN as SMART. You'll also need a username and password. Both username and password are: web" Using sakis3g, and setting the extra options with this information assisted the final operation. This was done after following the post of ManWe.

  • Sounds like it's a device with only proprietary windows drivers ( that are built into the device, which is why it pretends to be a cdrom at first ).
    – psusi
    Jan 19, 2012 at 15:47
  • @psusi, that is a good thought, so do you insinuate that this was done deliberately? Because the device is provided by Vodafone which do say that they support Linux, and do facilitate the Betavine project which supplies many drivers for these mobile broadband devices. I am hoping that this particular device is not one of the few which are made to work only under windows with the current software available.
    – Vass
    Jan 19, 2012 at 16:20

2 Answers 2


If the modem is recognised, but fails to connect check these (rfkill control wireless devices blocking on your system):

# get a list of devices and states
rfkill list

# unblock all wireless devices. With one integrated card this is not enough
# for some reason and I have to leave it "on" on Windows 7 to 
# get it to work on linux

rfkill unblock all

To fix mobile broadband with 12d1:14d1 id follow these instructions (not tested). Try creating this file to /etc/usb_modeswitch.d/12d1:14d1

# Vodafone/Huawei K3770

DefaultVendor= 0x12d1

TargetVendor=  0x12d1
TargetProduct= 0x14c9



or with this content

################################################## ######
# Huawei K3770

DefaultVendor= 0x12d1

TargetVendor= 0x12d1
TargetProduct= 0x1c05
MessageContent="55534243123456780000000000000011060000000000000000 000000000000"

After that test it with

sudo usb_modeswitch -v 0x12d1 -p 0x14d1 -c /etc/usb_modeswitch.d/12d1:14d1

And if it worked add to /lib/udev/rules.d/40-usb_modeswitch.rules these lines

# Huawei Ek3770
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="14d1", RUN+="usb_modeswitch '%b/%k'

And I think you need usb-modeswitch version of at least 1.1.8 I don't have your exact 3g-modem and if I'm not mistaken this stick is to be added to modeswitch databases at some point. You might get it to work with the devel version.

usb-modeswitch - switch mode of "multi-state" USB devices

** Building instructions, tried on ubuntu lucid **

@see http://www.draisberghof.de/usb_modeswitch/#download

as root run something like this (do not run this unless you understand what it does):

# remove usb-modeswitch installed from repos
dpkg -r usb-modeswitch
dpkg -r usb-modeswitch-data

cd /tmp
mkdir /tmp/compiledir
cd /tmp/compiledir
# get newest modeswitch at the time of this answer
wget http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-1.2.2.tar.bz2
wget http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-data-20120120.tar.bz2

# get required -dev files for compiling usb-modeswitch
apt-get build-dep usb-modeswitch

# install them
tar -jxf usb-modeswitch-1.2.2.tar.bz2 
cd usb-modeswitch-1.2.2
make install 
cd ..

tar -jxf usb-modeswitch-data-20120120.tar.bz2 
cd usb-modeswitch-data-20120120
make install 
cd ..
  • for testing usb_modeswitch I got "searching for target devices ... Found correct target device ... Mode switch succeeded. Bye." so I proceeded with the further steps. I tried betavine again but still it did not detect a device, and in the connection manager the device is not listed. I ran usb_modeswitch -e to get the version and it says: "* Version 1.1.0 (C) Josua Dietze 2010 * Based on libusb 0.1.12". So I should update this and how because the synaptic package manager has only this version? and how do I find the exact 3g-modem it is?
    – Vass
    Jan 22, 2012 at 1:26
  • 2
    Because I don't have your exact modem I cannot test this further than installing the binaries on my system. There still might be something missing in lucid that's needed to get the card working. So if this did not work, you should try yhis with ubuntu livecd or pendrive to see if usb_modeswitch started to work, but some other libraries or modules are missing.
    – Manwe
    Jan 22, 2012 at 1:58
  • I have the k3770 modem from Vodafone. After taking all the steps you wrote, I ran sakis3g, and it said that it connected! I used the option of old PAYG, which may not have been the correct option, but when I tried this again the same luck did not repeat. I also installed "modemmanager" I don't know if that was critical or not but after some fumbling around in the network manager an entry appeared for the Vodafone modem connection. It does not connect me but it is at least there.
    – Vass
    Jan 22, 2012 at 18:43
  • If you still have the pin in the sim card, I'd suggest to you to remove it (quite easy with a mobile phone). I remember some older software having problems with pin queries. Now that you can see it as a serial device or modem you should be able to find more tools and examples how to get it online. Also note that the ID for the device changes after usb_modeswitch so running manually multiple times the usb_modswitch command should be safe.
    – Manwe
    Jan 22, 2012 at 22:46

I have a Huawei mobile broadband device, it behaved the same in 10.04.

Connect the device, let it settle. Then unmount it via the Desktop icon, but don't unplug it. then check if it appears in the list when you create a new broadband connection in network manager.

If not, check if your device is listed in the usb_modeswitch known hardware list.

usb_modeswitch may not be installed properly. As a side note, from Ubuntu 10.10 I did not need to use usb_modeswitch, the device detected OOTB. Perhaps try a live-cd of 10.10 and if it detects okay, consider an upgrade.

update: See this help link on how to setup the modem in Ubuntu.

  • 1
    on the Desktop icon it is shown as VMB_10.2.102.30707_RP171 but this name is not listed anywhere on the net or in the known hardware list of usb_modeswitch, how else can I find the name if it is named otherwise actually? I think that usb_modeswitch should be installed properly since the man pages work and sakis3g should have installed it again if there was a problem (likewise for betavine). I tried unmounting to see if it appears in the list but it does not in the end. I will try the live CD approach. Should I try even newer maybe? (just to be sure?)
    – Vass
    Jan 19, 2012 at 22:03
  • See the update link I added in the answer, hope that helps.
    – invert
    Jan 20, 2012 at 8:26
  • I made a live usb of Ubuntu 10.10, and booted up the system, and it did not work. I tried sakis3G on it as well, and it still failed to connect. I will try the information given on the link you added in your update.
    – Vass
    Jan 20, 2012 at 13:47
  • from your link that you added to set up the modem in Ubuntu, when it asks to run "ls -la /dev/ttyU*" I get no files under this expression. And when running "sudo wdialconf /etc/wvdial.conf" it says that it scans ports for a modem but then it says that no modem was detected. I have tried all avenues I can see, is there any further direction?
    – Vass
    Jan 21, 2012 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .