I have just installed puppet master package in Debian 8 using apt-get but my puppet command is not working.

root@admin:/etc/puppet# puppet
-bash: puppet: command not found
root@admin:/etc/puppet# pwd

I have puppet folder in etc directory with following files and folders

root@admin:/etc/puppet# ls


Is there any way to fix ? I am also searching but when ever I tried to install puppet master using package I experienced this issue, no matter we try amazon linux, centos or RHEL, this issue always occur.

  • No, I have tried but there is no folder like that puppetlabs in opt. Jul 7, 2016 at 20:58

1 Answer 1


You are probably missing the puppet-common package. See if the file /usr/bin/puppet exists. If not then try installing puppet-common using apt-get install puppet-common.

Why this package is missing I don't know, it is a dependency from the master puppet package so it should have installed at the same time.

  • Ojs... exactly this is what I was missing every time....Thank you very much Jul 7, 2016 at 21:00
  • @ojs possible that he installed puppet 4 master (via puppet collections repo) and now has installed the puppet 3 agent via debian's repos.
    – jordanm
    Jul 7, 2016 at 21:28
  • No jordanm you are telling your experience. Its not like that Jul 7, 2016 at 23:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .