2
  1. I have virtual machine created from Virt-manager, it's Windows.
  2. I have attached host PCI device (GPU) to the guest VM, it's recognized, but not used
  3. I know options x-vga=on and -vga=none are friends of mine

But i have no idea how to apply them using Virt-manager GUI, where are no kinds of "X-VGA" and deleting primary display is ignored (set to "Cirrus" mode).

Without this, i cannot force guest OS to use attached GPU/VGA.

1 Answer 1

3

Most option you'll need to set using virsh and as far as the Cirrus Video card you must delete all displays first, this includes vnc/spice channels, then you can delete the card. I personally use it as a duplicate head and shut it off before attempting gaming. That way I have a spice channel.

Use this to define your domain schema.

<domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>

And this to send options directly to qemu (example show x-vga=on for the first shared host PCIe device):

<qemu:commandline>                                              
  <qemu:arg value='-set'/>                                          
  <qemu:arg value='device.hostdev0.x-vga=on'/>      
</qemu:commandline>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .